Tablo unusable out of the box - help! - Mostly solved

Received 4-tuner box on Saturday along with a WD 2TB elements HD (per recommended list).
Setup went smooth, updated to latest firmware 2.2.8, installed apps on 2 Roku 2’s and 1 Roku 1.
That’s when the (not) fun began.

We use Roku for Netflix, SlingTV, Amazon Prime, and Plex. Needed local channels, and antennas all over along with switching input was a hassle for the family.

After setup, Tablo can’t go for more than 5 minutes without a “Loading, please wait” message. Most threads I’ve seen have said that the problem has (mostly) been fixed with the latest versions of Roku and Tablo firmware. I’m on Roku software version 7.1.0 Build 4062, and today while trying to watch the NBA playoffs, it can’t go for more than 15 seconds without a loading, please wait. It’s been doing this continuously for the last 30 minutes.

1 Roku 2 is hardwired, and the other Roku 2 and the Roku 1 are wireless, and the problem occurs on all of them. My network is not saturated by any means, I can stream a 35GB Blu Ray file with no problems on any of these Rokus via Plex. The setting is set to the default (720). If I can’t get this resolved within a week, the Tablo is gonna have to go back. Any help is MUCH appreciated.


Is your Tablo hardwired or wireless?

You didn’t mention if the Tablo was wireless or wired into the router. I had problems until I wired mine directly to my router. The router is also important, as is the wireless connection to the streaming device. I thought my old router was pretty good, as it worked with most streaming services, but seemed to choke on Tablo. So, I updated from a Belkin N750DB to a TPlink Archer C7. Switching my wireless Rokus to the 5 GHz network made a difference as well.

Signal quality off the antenna is important as well, as there is a 4-way splitter inside the Tablo. Originally, I had another splitter ahead of the Tablo, so I could watch live TV off the TV’s built in tuners in addition t feeding the Tablo… getting rid of the external splitter boosted signal level at the input to the Tablo and got rid of some other problems I was having.

Running the latest software is important, and you seem to have that covered.

Anyway, this is my experience… hopefully, some of it will be helpful to you.

I think it’s your network, mate.

Your searches should also have turned up reports how people got these types of problems sorted by upgrading their router. I replaced my router with the Archer C7 (same as lkahhan) and all my “loading please wait” problems were resolved.


Also make sure you try the 720 (recommended) setting also. Starting there can be helpful and then going up or down until you find the sweet spot.

Thanks for the suggestions folks! Here are some more details:

My router is an AT&T provided model 5286AC unit. The Tablo is connected to a 1GB switch that is wired to the router. I’m using a Netgear Nighthawk R7000 as a wi-fi access point instead of the 5286AC, and the R7000 is connected to the same 1GB switch as the Tablo. I did this for wifi performance reasons. The router is tucked in a mechanical room in the corner of the basement and the wifi from it can’t reach the whole house consistently. The R7000 is centrally located on the second floor.

Regarding the antenna, I’m using a Mohu Leaf 50.

I’m also using the default 720 quality setting.

An update since yesterday:

When I got home from work tonight, my wife was watching the news via the Tablo. I asked how it was performing, and she said that it threw LPW for 5-10 minutes then it worked fine for the remainder of the broadcast (20 minutes or so). She changed the channel, proceeded by another 5-10 minutes of LPW, then it worked fine. This was on the wi-fi connected Roku2. I’ll mess with the hardwired unit tonight to see if I can replicate the issue there.

Thanks again for input and suggestions.

Can you try the 3 Msbp setting to see if it improves things?

There was someone a while ago who had a similar problem and they discovered the roku was placed close to another wifi device and the two wifis was causing interferences. The problem was resolved simply by moving the devices further apart.

I am baffled on the wired Roku, it should be working fine…

On the wireless one, however, the above suggestions might help.

An additional thing to look for is which frequency band the Roku is connecting on. I have had a Tablo for over a year with NO problems on multiple Rokus, all running wireless, even up to the 10MB setting. But then I set one up for my parents and despite the smaller home and newer router, I would get the LPWs constantly…

Long story short, the router I was using (Asus AC3200) has a “Smart Connect” feature that is supposed to help keep devices on whichever band is the best. No matter what I did, the Rokus kept defaulting to the 2.4Ghz band. I would get the Roku connected to the 5Ghz band, but by the time I got the Tablo channel up and running it would switch back to the 2.4…

Once I turned off smart connect and forced the Roku to the 5Ghz band, ALL problems went away.

I didn’t want to give up on the Smart connect for other devices as it worked just fine so I set up a guest network on the 5GHz band, labeled it “Roku Only” and connected them accordingly. Been great, again, even on the 10mb setting, for over a week now, not a single LPW…

1 Like

Tx for sharing! Hopefully this will help other folks experiencing similar issues.

I hope so too, I wouldn’t want anyone to go through the pain I did!

My mother is a hard sell on this whole cutting the cord thing but they really cant afford satellite anymore. I need this stuff to work perfectly if I have ANY chance of getting her to buy in and at first it was nowhere near perfect.

I immediately thought about the band issue, but I kept thinking it wasn’t making any difference as I could set it on any channel or any band and it continued to LPW… As said above though, regardless of what I set it on, it would default back. SO glad I noticed that or the Tablo would have been on its way back!

I am convinced the Wifi remotes of the Roku 3 & 4 are part of the problem. As I always do when setting up a new Wifi, I walked the property to look for possible conflicts nearby (neighbors with Wifi on the same channel). As I walked by the Rokus it would pick up the Wifi remote and for some weird reason the Roku kept trying to set them to the exact same band & channel as what the Roku was using to connect to the home Wifi… That cant be good for signal quality!

Either way though, whether its the Wifi remote or simply that the 5Ghz can transfer data faster, my problem was resolved by working around the “Smart Connect” and forcing a single channel & band for the Rokus only.

Partial success! Performed a few things, not sure which did the trick…

  1. rebooted Router
  2. rebooted wifi gateway
  3. rebooted all Rokus
  4. rebooted Tablo
  5. changed record quality (does it affect Live TV?) to 720 - 3Mbps
  6. Moved wifi Rokus (both 1 & 2) away from TV a bit in the event there’s wifi interference.

At this point all Rokus are working much better. That’s not to say perfect. We still get LPW occassionally (1-2 times per hour). I’d say the majority of our issues with LPW occur late afternoon / early evening. Later in the evening (>9:30 or so) they go away completely.

Thanks to everyone for help and suggestions!!

Daniel, if I have further issues, I’ll definitely keep the 2.4 vs 5 GHz band swap in mind.

Regarding wifi interference, that’s a (slight) possibility. Previously I used both an Apple TV and a Raspberry PI. Had then stacked on top of one another and wifi perofrmnace was terrible. Moved them away from each other and performance returned to normal. For my wifi Rokus (model 1 & 2), I didn’t have issues with any other apps, but moved them clear of other potential sources of interference nonetheless.

Yes - this setting affects both live & recorded TV.

Glad to hear things are working better!