Tablo Roku App (4th Gen) Update (v. 0.8.600)

I meant 0.8.600

Are you saying your tablo device crashes? or the App crashes on your Roku?

1 Like

I would try an extra Roku reboot as well as trying a Tablo reboot.

Also, when you delete an app, reboot the device before reinstalling it to make sure all data is gone so that it won’t keep any lingering issues begging and shove them back into the reinstalled app.

If nothing else, try a Roku cache clear/reset/reboot through the special key presses.

Keep us posted!

1 Like

I’m having same problem. my gen 4, 4tuner was mostly trouble free until the 0.8.600 update.

Now crashes when I try to view Live or library recordings. Once in a while it gives the “Playback failed. Retry?” error, but 99% just crashes.

Odd thing is, I can watch Live or recorded shows thru Tablo app on my phone.

Tablo gen 4, 4tuner thru Roku 4k streaming stick.

It’s the Roku app crashing as I can be logged in through the Tablo app on my iphone and it works fine.

My Tablo is also a 4 tuner…. I’m having the same issue with multiple Roku devices… Some are Roku TVs while others are streaming sticks. The Tablo itself is not crashing… it’s just the app on any of my Roku devices.

I also can watch live TV through the Roku app without it crashing… just can’t use the Roku device to watch recorded shows.

Is there any way to go back to a previous version of the Roku app when it was working fine?

I’ve tried removing and reinstalling the Roku app, doing a reboot/refresh on Roku using special button presses, hard rebooting the Tablo, and removing my external hard drive from the Tablo.

Nothing has helped. Roku app still crashes every time when trying to view previously recorded content.

It seems clearly related to the Roku app (0.8.600) itself since the Tablo runs trouble free from the iPhone Tablo app and the previous version (0.8.500?) ran without issues

BTW, the Roku OS is 12.5.5 and (one of my) Roku model is 7131X.

Does anyone with a 4 tuner gen 4 Tablo not have this problem with the Roku app?

1 Like

@Tyler I have a Gen 4 / 4-tuner Tablo and have not had this problem with the Roku app. I have a Roku Soundbar, Ultra and 4K Streaming stick and no issues with any of them since 0.8.600.

If you’ve removed your external drive from your Tablo, you have to reformat it again to use it.

I have not had any problems with removing and reattaching my external hard drive. It continues to record and play back programs via the iPhone Tablo app.

Hmm, there goes that theory…

I have 3 different TVs I use. Two have Roku built in (TCL TVs) and one has a Roku usb stick (not sure the exact model). I found one of my TVs is still using version 0.8.500 but it also crashes the Roku app when trying to view recorded content. So I guess it is not related 0.8.600 after all…. Just coincidentally stopped working around the time that version came out.

I’ve only had the Tablo for about 3 weeks. All TVs worked great through their Roku app for the first couple weeks… and then all stopped working in unison. Same failing signature where if I try to view recorded content the Roku Tablo app exists to the main Roku menu. Again, the Tablo itself is working fine through the iPhone app even in parallel to when the Roku app crashing.

But maybe it is the Tablo after all? It is the only common thread between all the different setups not working. Should I swap it for a new one? I still have 1 more week left where I can return this one to Best Buy…. I would rather not start over, but without the Roku app working it is fairly useless to me.

I’ve tried all the suggestions given on this thread so far (thanks for the tips) and then some (like removing my external hard drive) without success.

BTW, here are the 3 TV setups where this Roku app is crashing:

Master Bedroom:
TCL Roku TV
Ver 0.8.600
Model: 7131X
OS: 12.5.5

Living Room:
LG TV using Roku stick (not sure the model)
Ver 0.8.600
Model: 3941X2
OS: 12.5.5

Patio:
TCL Roku TV
0.8.500 (this is the one not updated to 600)
Model: G136X
OS: 12.5.5

Your using Rokus is also a common thread… Especially if it works on other hardware…

I have 7 Roku devices in my home. When the app was crashing on me (regardless of the firmware/app version)… it usually from low RF signal. I don’t think the Tablo Roku APP knows how to handle pixeling and choppy video feed.

Also my Tablo Roku APP crashed when I had low WiFi signal to my Roku devices.

1 Like

Just a thought…is your external HD on the compatibility list that Tablo recommends? Maybe try removing the HD and record to the internal HD and see if it works. This would at least determine if it were possibly the external HD.

1 Like

Unless something’s changed in the last couple of months… Once you pull out your HD and record to your internal drive, it won’t record to the external HD without being reformatted and set up again.

This has been my experience as well as what the support pages have stated. That’s why I wondered about this earlier.

Besides, I believe the Tablo needs to be rebooted to realize that you’re now recording onto the internal drive. This would remove the drive from the system’s memory and help to ensure it’s recording to the correct place now.

I concur. :+1:

1 Like

When I pulled the external HD out of the Tablo, I never actually tried to record new shows using just the internal HD.

What I did was pull the HD USB connection, then checked the Roku Tablo settings showing the external HD was indeed no longer present, and then went to view the recorded shows (which should have been none) which caused it to crash out of the Roku Tablo app just like it did with the external HD plugged in. I then reinserted the HD USB and could again see the HD in the Roku Tablo’s settings. Of course, the app crashing still occurs.

Note, I have several TV series set to record which has been working like clockwork and continues to work both before and after I tried the experiment of removing the HD from the setup. I know this because I can see the available storage change daily plus I can see the new content when using the iPhone Tablo app. I just never tried recording a show to the internal HD because the app crashing behavior happened just by the act of trying to view the recorded content. And just to be clear, when I say I am just viewing the recorded content I have not even selected a recorded show to play back… I’m just trying to view what has been recorded which causes the app to crash every time like clockwork across the 3 different Roku setups I described earlier.

Also, the RF signal from the antenna seems good too. Show strong signals across most channels in the setup. I can actually watch live TV on the Roku Tablo app just fine and the recorded content looks good when using my iPhone app… I just can’t view any previously recorded content using Roku’s app.

BTW, my HD is a brand new 5 TB USB 3.0 Seagate from Costco. I’m not sure if this is on the Tablo compatibility list or not, but it seems to be working fine outside of the Roku app.

It’s true that the Roku(s) is/are the main commonality in my Tablo problems. The Tablo is working well outside of the Roku app… but maybe something is wrong with my particular Tablo when it comes to its interaction with the Roku app since others on this thread (besides mgo_davis) are not experiencing this Tablo/Roku behavior.

Ordering another Tablo and returning this one would allow me to test this theory. This would be a pain, but I really want Tablo to work with my Roku devices since I am heavily invested in the Roku platform around my house. My first few weeks experience was great across all my Roku TVs… even my wife was happy with it which says a lot… but then every Roku playback option broke at once… and all my debugging efforts are not going well.

Great lengthy explanation. I appreciate the response.

I know that you’ve mentioned rebooting the Tablo itself at some point, and just to confirm, you’ve done that since your HD pull attempt?

I find it strange that you’re able to watch live TV through the Tablo but not your recordings. It still needs the drive to do this, so that’s weird!

I was having an issue a couple months back where I was having a ton of buffering. I unplugged the Tablo, disconnected everything piece by piece (not the antenna) and made sure to reseat everything that was going to connect to my Tablo (this was my 4-tuner, btw). This included disconnecting both ends of the hard drive cable, etc. I also used a can of air to clean out these ports before plugging everything in again, and this has seemed to have worked – just an idea.

I’m also curious… could you describe the steps that are happening as you try to play a recording? I’m trying to figure out where the issue starts – getting to the library? Opening the series? Once you press “watch episode”? etc…

I did the Tablo power reboot before I attempted to remove the HD. I’ll try again tonight by doing the reboot after the HD is removed.

And it is the act of getting to the recorded library where the crash occurs. It shows the spinning circle (as if looking up all the recorded content to display to choose from) but then crashes after a few seconds before it displays a single thing that was recorded.

Even with the HD removed and therefore there was nothing to display it did the same thing… Spinning circle as if looking on the (internal?) HD and then crashed. Of course this was without a reboot so I’ll try that tonight.

If you reboot the Tablo while the HD is not attached, you might lose those recordings… so I don’t recommend that. I was asking if you’d rebooted the Tablo after plugging it back in and if you were still having these issue.

So, if I’m reading that right, as soon as you click on the library tab, you get a spinning circle and it crashes? Or is it past that point?