Tablo Ripper - Automatically download new recordings


And as a piece of info regarding the earlier posts in this thread about does it pass surround sound. I just got off the phone this morning with TABLO asking if they had fixed the surround sound issue and they admitted they have not. If you have a home with a few ROKU units talking to the TABLO, and one of them is NOT surround sound enabled, you must disable surround sound encoding for ALL since it is a common setup for all. So if surround is important to you, you must put at least a simple surround speaker set on each location using the ROKU so TABLO will allow you to set the SURROUND SOUND check box.


First, I want to agree with your underlying message, which is the Tablo surround sound feature should be enhanced to allow enabling, and disabling surround sound per media player device.

Into a little semantics.
The Tablo surround sound feature performs as documented, so it’s not actually a bug that needs to be fixed, but rather an enhancement that is desired to be added.

The important distinction between bugs, and enhancements is customer complaints about bugs tend to be way more powerful, than complaints about desired features.


actually it was documented this way because after testing they found that storing both stereo and surround streams was causing audio sync issues. So it isn’t that there is not a “bug”. Its that to make sure the bug did not affect sales they just made sure it could do only one audio stream type. Problem fixed.


Respectfully, we’re rabbit-holing semantics, so let’s agree to disagree on that point.


Hi. I used tablo ripper in the past with no issues, but I tried again to use it this week and I get a strange error message. It says “Exception: Access to the path ‘C:\Program Files\TabloRipper\tmp’ is denied.” I tried unistalling and reinstalling the program but have the same error message. Any suggestions on getting it working again? Thanks.


Easy enough - pick a different output folder! Windows won’t let you write in the installation directory.



I have a dual 4K monitor setup, and Tablo Ripper 2.4.1 (64bit) opens up in a small window, and I can’t increase its size. I can’t drag it bigger from any corner. I can only see about 2/3rds of the program window, and while still usable, having to scroll to get to the buttons at the top and bottom & left and right. I’ve tried unchecking the box in settings to save size on exit, and that didn’t help. Everything else seems to work like a champ.

I can drag the bottom right and make the window smaller yet, but never big enough to see the entire program. If I were to guess, 640x480px or smaller.

Any thoughts?


Yep, sorry. You have a really high resolution display, and probably cranked up your system font magnification significantly to be able to read them. I never got around to implementing “auto-resize” in the TabloRipper GUI which would have allowed it to better “scale” to your configuration.


Yep, Windows display properties is set to a “custom scale factor is set”, and I can’t even tell you what percentage it’s set to. If I were to guess, it’s probably 125-150%, based on the amount I have to scroll. :slight_smile: Whatever it is, icons and txt is readable, and I spend 90% of my life in SSH sessions, so I’m happy.

Thanks again for your program. Saved hours of my life deleting ~300 recordings.


I’m new to Tablo - and I’m really interested in contributing to this project - was super happy to see that the project was hosted on github but it looks like it isn’t public (the code that is).

Is there a formal way to help out?


Thanks. I’ll send you a PM.


Wow, this is such a great, app, simple to use and works perfectly for me!


I do have a question. With the release of a commercial skip feature on the Tablo, would you be able to include their commercial markers in the ripped mp4? That would be awesome (especially if it does a good job detecting commercials) because then mcebuddy could use the chapter markers to remove the commercials … much faster, easier processing.


This would be an awesome option!


I don’t believe Tablo Ripper is being actively developed at this time.

Doesn’t directly address your question but there is a third-party developed Android app that is planning on supporting the commercial skip functionality…


At the risk of repeating myself:

Post #1304, Oct 26, '18 10:31 AM


@CycleJ , do you think @llavalle would be willing and able to implement this feature? Not sure how the PMing went


TabloRipper isn’t open source due to the Nuvyyo NDA I signed to gain API access (which was well worth it IMHO). So @llavalle and I aren’t collaborating.

But I’m under the impression he is going to do their own thing, so stay tuned and see how that goes.

Honestly, I had very few (if any) issues with how MCEBuddy/Comskip performs. Not perfect, but is plenty good enough for my purposes.


Hi! Just for clarity (thanks for the mention @Nilex!) ota2GO fits a very different target than TabloRipper, which is excellent at doing what it sets out to do! - ota2go is not really geared at ripping to fill one’s library - more geared at taking a few shows on the go as you travel. Though of course the patient users can rip a few at a time and move them off to a library elsewhere.

The commercial skip support in ota2go is that in the internal video player, it will automatically skip commercials as it is playing (like the Roku app etc). This is the case for downloaded shows or ones streamed from the Tablo.

I haven’t implemented stripping of commercials on the downloads themselves, for 2 reasons: 1) If the comskip markers aren’t accurate, you’re hosed if you rip and trust them, and 2) I dunno, it kind of feels like cheating to me - the commercials are largely what pay for us to get this content OTA (along with gov’t requirements, of course). #2 is subjective and that’s just me :slight_smile:

In any case, in the short term, ota2go will give android users a free option to watch on their phones/tablets with comskip until Tablo builds that in to their own android app.


  • Steve


@CycleJ and @arskiracer - you guys are both correct. I was under the impression that an opensource version would be possible but was informed of the NDA. Because of that - it complicates thing. Thought about adding some features (for myself then release them) but that’ll be weird.

Went thru the NDA process but I’ve been traveling for work for the past 2 days so I only glanced at the documentation - briefly.

Unsure of my current path forward right now - I may want to discuss with @CycleJ on a possible collab but I’m not even sure that’s an option (for both of us or the NDA or else). Oh, and I’m an “He” :slight_smile: