Tablo losses connection frequently "A connection to your Tablo cannot be found"

I have only had my 4-tuner Tablo 2 weeks and have used it to record many shows, but have not watched much of what I recorded until this week. So far I ran into problems enough times to make me worry I made a poor choice. One show said it recorded the full episode, but only recorded half of it. And I have lost connection several times at random times. Tonight I was watching a program and the program was pixelated so I assumed it was just something with the Antenna, but then eventually Tablo gave out and now will not connect.

The first time this happened, I thought it was a fluke, so I tried resetting it, which didn’t help. I unplugged it and when I put it back on it was better. I tried holding the reset button for 30 seconds, but it didn’t help.

I know this connection error is not my set up. My Roku 4 is working flawlessly, my internet on my phone and laptop each have no issues and my Tablo is hardwired to the router. I have looked for the Tablo on my phone, Roku 4, and Laptop. Nothing can connect and the Roku 4 doesn’t even see the Tablo as mine it just sees it as a 4 tuner.

Are these known issues with Tablo? Could they be due to an automatic update happening? I do have a ticket in with Tablo support, but it was for the half recorded program, I’m not really sure what to do.

If you held the reset button for 30 seconds + it means you factory reset your tablo. You may have lost your recordings in the process.

Try reinstalling your Tablo apps on your devices / clear your browser cache.

1 Like

I had problems with pixelated and short recordings. That’s apparently usually bad signal strength. I upgraded my antenna and haven’t had problems since.


The “factory reset” did nothing, apparently my reset button does not work. Good news is I didn’t lose any recordings. Unplugging the power and plugging it back in works, but I feel I should not have to do this every week.

Did that blue light flash when you were holding the reset button? I think it is supposed to. But if you have a broken reset button you should call the support.

@HobbesGrrr We agree - you definitely shouldn’t have to do this every week. If you haven’t already, please touch base with our support team. We’ll get this fixed up.

I have a ticket in with support (14348). I watched one show last night and then when I started a second one the Tablo died again. I didn’t reset it or try to this time, I am using my old DVR instead. Hopefully we will figure out the problem soon, from what I read on here it is a great device when it actually works. The good thing is, I think it is recording shows, I just can’t watch them.