Tablo dual no longer working

After using my dual tuner Tablo for six months it all of a sudden stopped working. I bought it back in October 2015 and it was last seen on the network 3/28/2016 according to the details in my account. It was working fine on wifi and then all of a sudden it just stopped working. I cannot connect from my iPad or Windows PC while on the Tablo wifi network with the app or browser. I also tried connecting it to my wired ethernet and cannot connect to it with iPad app or Chrome browser(fqdn nor IP) or PC With browser(chrome) (fqdn nor IP). I tried doing a factory reset same results.
It is seen by my router as a connected device and I can ping it.
I will be calling support sometime next week when I am home during the day but was hoping maybe someone has some other advice while I’m waiting.

Is there any sort of SSH access or API access?

Very frustrated,

Try rebooting your router?

If it’s actually dead good thing it has a one year manufacturer’s warranty. Support will get you fixed up.

@Tgbennett If you have contacted our support team, make sure to include your Tablo’s MAC address. We can narrow things down quickly this way. We’ll get this sorted out.

1 Like

I called and the only option is to leave a message. I am usually not available during the hours your support person is and not being able to get the support rep on the phone when i call stinks. Hopefully they will get back to me today.


I call either on break or lunch. But I agree late a couple of nights per week or 4 hours on a Saturday - say 9 am to 1 pm Eastern time.

I am having a similar problem.

I cannot connect to tablo with computer which is needed to schedule recordings manually.

After attempting a few times I get “The connection to your Tablo was unexpectedly lost.”

I have tried clearing the cache and cookies in chrome, and restarted all devices involved.

I can determine the tablo IP from the router’s DHCP list, and can successfully ping the tablo. It is a wired connection and the roku can communicate with it.

I submitted a support request yesterday, and received and email saying they will get back to me soon. I replied giving the mac address. I tried calling but only had the option to leave a message. So, I figure what I am doing via email is probably just as good.

Call 9:30-5:30 Eastern Monday thru Friday. If a male recording answers, hang up and try again in an hour. If a lady recording, stay there and wait.

It turned out to be a bad memory module. The return and shipping of the new device was much smoother than the diagnosis. They might want to look into some different/multiple support methods. (Constructive criticism)


Mine was problematic. Blue light was on solid. No blinking. Turned out to be the power supply brick.