Tablo Dual Lite never recognized

I bought a Dual Lite on Sunday and am still trying to get it to work. I plugged it in per instructions, downloaded the app on my iPad and just can’t get it to do anything. The app never ‘retrieves’ my Tablo. I can’t retrieve it via web browser and I can’t retrieve it via my Roku. I’ve read all the FAQ’s and tried unplugging it, letting it sit, but it just sits and blinks its blue light (about once per sedon). I sent an email to tech support 2 days ago, and I’m still waiting for a response.

Did I get a dud. Any ideas??? Thanks

Is it connected to a wired or wi-fi network? The blinking blue light makes me think it is wi-fi. If so, make sure you follow the steps for wi-fi carefully:

The blinking blue light once per second means it isn’t connecting to your network.


Sorry. Should have said it it hardwired to my router

I assume you have the orange and green lights?

Make sure the Ethernet port on your router is connected to your Tablo.
The orange LED on the Tablo Ethernet port should be illuminated and the green LED should blink periodically.

Tablo had problem with the ipads not working on tablo, think they didn’t resolve it yet try a PC if you can or android device hope that helps

Both orange and green lights are on steady. No blinking

Do you have a modem / router combo?

Or do you have separate devices for a modem and a router?

If two separate devices you want to make sure the Tablo is hard wired to the correct device.


I finally heard back fro Tablo Support who suggested a couple of things. Plugging and unplugging the Ethernet cable didn’t do anything on the surface, but what I did was a full system reset of the device (unplugging Tablo, pressing and holding blue button on back while plugging it back in). I also completely rebooted my entire home network. Starting at the modem, the router and the Tablo. One theory I tested was removing all devices from the router so I could see if Tablo really was building it’s own ISDN. So, after complete household reset of my network and resetting the Tablo, i plugged in just the Tablo. it finally worked. It found it on the iPad app and I completed the setup on my laptop. Thanks for all who gave advice