Static IP for Tablo Connect Purposes

I am sure they are out there but I have seen quite a few, and every single one I have touched (clearly i haven’t touched them all) have the ability to at very least set a static ip for a device connecting to the DHCP server side via mac address.


Im actually suprised that these types of routers even exist nowadays… MAYBE i could see it on a ISP provided router (to qhich i would say, don’t use their crap :smiley:  )

pfsense all the way.

If you directly access the Tablo NIC interface and set a static address inside of Tablo, and then you change routers because YOUR router died and the new one uses a slightly different IP scheme, say 192.168.1.0/24 instead of 192.168.0.0/24 which happens now and then, then what? You can’t get to the Tablo because the IP is stuck on a network range that your new router isn’t configured for and you have to change your new router before you get to the Tablo.


I see zero issues with a reserved IP in the router. It’s pretty easy in quality routers, even fairly cheap ones these days and ensures that no matter what happens on the rest of the network, Tablo can be found or seen or accessed. 

Most routers are smart enough to not assign a DHCP address that matches a static address.

Maybe of those you’ve seen, but I’ve seen quite a few higher end systems still assign an address if the device doesn’t respond instantly when queried. I still see occasional “IP address conflict” messages on systems I work with. 


IMO, address reservation is the best for most home networks, even some business cases (networking is what I do all day for a government agency)
It avoids hassles connected with other network device changes.
Even some of our LAN-to-LAN connections are based on reserved addresses as the ISP was for a while constantly building out their plant and addresses kept changing but we couldn’t go pure DHCP as our base router allowed connections only if the outside IP addresses of the remote routers matched our profiles here.
We do STATIC for most servers, switches, many printers and routers as those need to be entered into DNS as static for multiple reasons beyond the scope of this forum. Our workstations or PCs we use in IT are on reserved addresses, not static. 

@snowcat I have a Cisco ASA5505 running older software that cannot be upgraded due to lack of support plan with Cisco.

@greymont

That is a very expensive piece of hardware. Is it actually lacking such a basic function of DHCP reservation?

1 Like

I cannot figure out how. Others have tried:
http://arstechnica.com/civis/viewtopic.php?f=10&t=134984

I consider the Tablo to be a network infrastructure device like a switch, file server, domain controller, or other device that must be known to the network at a given location to function correctly. All other devices I have seen that are similar network infrastructure allow for statc IP assignment. Including all network printers. Seems really wierd to not have it as an option, even if a hidden one that can only be activated by the subset of users who really need it.

Roku doesn’t allow you to assign a static IP either. I think it is becoming more and more the standard as networking becomes more and more necessary for the average Joe.

If Tablo just worked, like Roku, I would not have a problem with it using DHCP. But it doesn’t.

2 Likes

@greymont

What does not work because you cannot set a static IP for the Tablo? The only thing I can think of is Tablo Connect.

Which is exactly the problem I have.

Roku, Fire TV, and TV’s for that matter, are end user appliances. They can work differently and I can see why they might not have this capability. But Tablo is a server. A different thing on the network.

Look, static IP assignment has been the backstop solution for networking problems simply forever. Every networking colleague I have has depended on it at one time of another to solve problems that just do not seem to have any other solution. Why abandon it now in this product?

I cannot believe it already exists as a capability within the Tablo unit. After all, as a developer wouldn’t you implement this first? I would just like to be let in on how to use it.

To be fair the ability to assign a static IP from within the router is pretty standard, my old WRT54G even had that ability as I recall.

I DO have DHCP reservation configured. Last night around 10 PM I lost electrical power and it was still off when I left this morning at 7 AM. When I got home at 11 AM power had been restored. I didn’t think to check my Tablo remote access. When I tried to watch it while out, it was taking forever to connect, so I figured the Tablo was doing its old tricks and left it alone until I got home. I put my phone on WiFi, connected to Tablo and it said I had to manually configure my router (which I had already done). To fix it, I unchecked Remote Access, and checked it again. It now works.

PLEASE at least give us an option to run a static IP and handle the networking ourselves. IF you were to go away, with the current setup we will all have boat anchors. IF there was an option where it did not need to go to tablotv.com then it would continue to work even if you go out of business or brought out we could still use our Tablo.

@beastman

  1. After the power outage, was the Tablo actually in fact the same IP as it was previously?
  2. Likely your WAN IP changed after the modem reboot and thus the remote device had to just be repaired locally with the Tablo. Sometimes even when the Tablo Connect is not broken and it still works, the Tablo itself reports the ports are not forwarded. I have had this error noted once or twice and yet I could still connect remotely. Yes, it is insane.

The LAN IP was the same, but with the power being out for so long, I bet I had a new IP address from Roadrunner. IF I was running my own server, the NO0IO client would have updated my record. Tablo needs to allow for NAMES in addition to numbers. People that actually have a static IP can use the number, but for the rest of us, there will me a name

@beastman

Next time, even if the Tablo Settings page gives you the error, before turning OFF and ON the Tablo Connect feature, just re-pair locally and try to connect remote after. It likely will work.

@theuser86 I had my phone in WiFi and opened the Tablo app. It connected. I then went to settings and scrolled down to Remote access. How do you pair locally? I thought by having my phone in WiFi and use Connect that it does pair. If it does, then why waw the remote still saying I had to configure my router? Should I have closed Tablo app, turn Wifi off, and open the Tablo app and see if it worked prior to unchecking and rechecking? Hopefully I don’t lose power again any time soon.

I’ve seen this happen and my “fix” is/was to uncheck and recheck the Tablo remote access box.

Sure would be a lot less trouble with a system generated code or password for a limited number of remote clients. I say limited number of users/clients because I realize the potential for abuse beyond immediate households.

I would try to just increase the lease time if your router does not support static assignments. If the pool is large enough not to have to recover addresses often, then you should never run into devices getting different addresses. If it still ends up being a problem, I would focus on getting a different router or moving the DHCP services for your network to a different device that has more features. It is much easier to manage all IPs from your DHCP server vs touching each device manually.

@beastman

“How do you pair locally? I thought by having my phone in WiFi and use Connect that it does pair.”

–> This is correct. Connecting to your Tablo locally (aka on the same network) pairs the phone with the Tablo.

“Should I have closed Tablo app, turn Wifi off, and open the Tablo app and see if it worked prior to unchecking and rechecking?”

–> Yes, you should have tried this first. It usually still works after re-pairing even if it gives you the error as long as the Internal IP has remained unchanged.

Static IP is a basic option in my opinion. I know that some DHCP server allow for reservation. I’m using DHCP off a Cisco 3750G switch and that doesn’t have that option.

Maybe only make it available for the wired versions…

A switch does not have a DHCP server which assigns IP addresses so may be you’re looking at the wrong networking device to configure it. Which device is your router?