So far not so good

So, I just took delivery of a new 4-tuner Tablo and attempted setup. Even though it does not appear that the Tablo supports my preferred network topology, I decided to go the simple route and add it via WiFi directly to my home network.

I unboxed it, plugged in my new vetted WD Elements 2TB drive, outdoor antenna and finally power. I followed the instructions for WiFi in the Quick Start Guide:

Launch iPad Tablo app
Join the Tablo_XXXX network
Return to app, select home network, enter password
At this point the iPad is dropped from the Tablo WiFi network and rejoins my home network
It spins on Setting up Wi-Fi for a while and then eventually throws up a dialog saying that it cannot find a Tablo on the Wi-Fi network.

and that’s it. I can get no further than this. I’m going to reserve my complaints about the inflexibility of the Tablo networking model for now, I just would like to get this going in the simplest way possible, which I thought would be sticking it on the same WiFi network as most of my devices.

Any insights?

Sounds like you are doing everything right. Might try rebooting modem then rebooting Tablo and see if that works. Might also check you modem/router configuration page and see if Tablo has an address.

Try first getting it to work without wifi by connecting the Tablo directly to the router via wire. Then when that is working enable wifi before unplugging the Ethernet cable.

Thanks. I’ve rebooted the Tablo several times while trying various things. I’ve checked the router and the Tablo does indeed have an IP, and it is on the same /24 net as the iPad. Perhaps I’m misunderstanding how things are supposed to work. I assume that with the client and the Tablo are on the same subnet, the client should be able to connect. What did I miss?

Unfortunately, setting this up wired is more involved than just plugging the Tablo into my router. My wired LAN is not on the same subnet as my wireless bridge. This is on purpose, before anyone tells me to change it. Which gets to my comment about inflexible network topology in my original post.

Yes the typical / average / normal consumer/user has one router which runs both the wired LAN and wireless LAN as one unified network. It is simple, it is straightforward.


Regardless, I’ve attempted to set my Tablo up out of the box in one of the recommended/supported configurations and it still doesn’t work. There’s obviously something not being said in the user guide. Can anyone point me in the right direction before I box this up and send it back?

Does your wireless bridge have an Ethernet port?

If the Tablo is getting an IP, can you ping it?

The only other thing I can think of is to kill the iOS app and restart it. Maybe it cached the Tablo network settings?

@Zzz - Please touch base with Tablo Support. The networking gurus can help you find a way to (hopefully) make Tablo work on your unusual network:

1 Like

I will contact support, but you’re not listening. I have abandoned my “unusual network” for the purposes of Tablo. I am attempting to add the Tablo to my wireless network just as recommended in the guide. All of my client devices are connected to this same wireless network. How is that unusual?

Now that you’re brought it up, though, my “unusual network” is only unusual in the eyes of Nuvyyo, everywhere else on the planet it is one of many normal ways of securing your network. While you guys are patting yourselves on the back for your clever security mechanism for the Tablo, you’ve completely neglected the fact that there are established standard ways of doing things, and by not allowing more flexibility in configuration you’ve reduced the number of installations in which the Tablo works out of the box.

I’m not suggesting that there isn’t something in my network that is causing issues (though in this case packets should never need to leave the subnet), but just that you can’t expect everyone to network things the way that you think they should. Networking has existed for a long time before Tablo and your view of how it should work is very narrow.

xxx ccc xx cc


Fair enough, but in this case I’m not attempting to step beyond. How I would like to deploy Tablo and how I have attempted to do it are very different. I recognized fairly quickly that my preferred method is not supported and decided to simply go with their recommendation so as not to create problems. Sigh.

I think it’s more than simply supporting the common type of network. Nuvyyo have decided to implement an auth mechanism by which client and server are “paired” by first connecting on a local network and then are automatically authenticated for wide area access. This is clever and, as you’ve said, for the common case doesn’t require the user to know much to get it to work. It has the cost, however, of making some standard configurations not work and that doesn’t have to be the case. People know how to authenticate to services, they’ve been doing it since the dawn of the internet and I don’t think it’s too much to ask to support it as an alternate method for those that would like the additional flexibility.

I’ve seen other threads on this forum in which users have asked for this flexibility and it seems that a common answer is “what do you want to do that for?” This smacks of the Microsoftian, we know what’s best for you, mentality. It doesn’t seem a good tack for a startup.

Please understand that I’m not here to bash Nuvyyo. I bought the device because I want to support this effort; I want them to succeed. I’ve even given them the benefit of the doubt in that my preferred platform, the 4th gen Apple TV, doesn’t yet have a native client. I’m giving them a vote of confidence by purchasing now. No amount of my wishing it so will make it happen, though. In the end they will need to provide a superior solution; one that works well for their customers out of the box. As I say in the title, so far, not so good.

xxx ccc xx cc

Have you tried doing a full reset? I’ve done this a few times and it has helped, but of course it also reformats the HD.


So, I’ve managed to work around my issue by connecting directly to my wireless base station via ethernet, running through the initial configuration, and then enabling wireless on the Tablo. This involved climbing up in the attic with a ridiculously long ethernet cable so that I could reach the Tablo which was tethered to the outside antenna. This sort of defeats the purpose of having wireless setup.

It seems to me that there is a real problem with the existing wireless setup process on shipping units. I bought this from Amazon and (I eventually found out that) it shipped with firmware 2.1.x. Once this was set up via ethernet my clients had no problem finding it on the wireless network. The same network that failed to work with wifi setup.

I contacted support as suggested but have yet to hear back from anyone. Since initial setup of this I have upgraded the firmware on the device so I’m not sure whether that changes the behavior of this particular issue, but I’d be willing to work with someone in support if they’re interested in trying to root cause this. At some point, though, I’m going to punt and just move on to trying to use it.

Is your attic air conditioned? Your tablo might have issues if it is exposed to the elements for an extended period of time. Mine did not work in the attic very well so I moved it back into the house.

Also, I chuckled a little (no offense to yoi) when you said that Microsoft has the mentality of making choices for you because “they know best”, and then said your TV platform of choice is Apple TV. I can’t think of any company more controlling than Apple.

Joking aside, I hope we can help this work for you, Tablo is an awesome piece of technology when you get it working.

My Tablo is not in the attic, my base station is.