Seagate Backup Plus Slim 2tb - Hard Drive not recognized

I bought the 4 tuner tablo now over a week and still cant get a HD to work. this is really frustrating me. I saw in this thread that the subject drive would be fine, ordered it, installed it with the same results. Tablo, help me out, I am near the return to vendor stage.

  1. Does the HDD initialize properly on a computer?
  2. Does the HDD even power up when you connect it to either USB port on the Tablo?

Plug the hard drive into your computer USB port and delete the hard drives partition. Then plug it back into the Tablo it should start a format.

1 Like

it does power up, and I quick formatted it on thee computer with no issue.

Go into disk management on the computer, delete all partitions from the drive. Then plug it back into the Tablo.

I went to disk management and deleted the volumn, then plugged it in to the tablo and reset, still shows no drive found.

Can you plug your phone into the USB ports and see if it charges? The USB ports might be dead.

You might have to power cycle the Tablo too after plugging the drive into it (aka reboot it).

rebooted the tablo device and tried different usb ports, same result, hd light on, tablo booted, guide is there, no hd found

What setup are you using? Have you tried an iPad or website in the Chrome browser?

plugged the phone into both usb ports, booth charge the phone

using tablo off the xbox one with firmware 2.2.12

Can you please factory reset the Tablo?

And then use a computer or iPad to do the initial setup?

As to how to do the factory reset, please follow the directions below.

factory reset didn’t work either, I am trying a hard format on the drive, if this doesn’t work, its heading back to amazon.

What setup device are you using? Still the Xbox?

I used tablet pc, still no luck even with the hard format.

@flumley Sorry to hear you’re having such a hard time with your HD.

If you pop a note to support they can help diagnose where the issue is. Given that there’s power to the ports, I would guess it might be with the connector on the HD. Do you have another connector hanging around?

Either way, drop us a note so we can give you a hand:

I’m having the exact same problem with the same hard drive – the Tablo won’t recognize it. Any chance this will get resolved soon, or should I return and exchange it for different one?