Roku stick not showing recordings

The Tablo channel on the Roku stick is not showing recordings.  I can see the recordings on the web based app on the computer, but it is not showing on the Roku Stick.  I tried rebooting the stick and also deleting and adding the channel back, but the recordings are still not showing.  Any help please.  Thank You.

@acronym3 try different sorts, I have mentioned this issue that the default sort misses some shows

To clarify what Jestep said, The A-Z listing will show all recordings.  If that is blank, then there definitely is a problem.

@snowcat, yes that is exactly the problem. Title A-Z is default and does not show all my recordings. Funny thing is I can see them loading when the processing box is up. Also, moving to another does not show the artwork until I scroll down, might be by design.

I also just looked and Most Recent does not show all my shows either.

And with the newer 6.1 Roku and the latest Tablo there is also a weird issue that the show displays to the left but when I scroll down the show pops to the middle… Issue or by Design? :wink:

@Jestep We just noticed this recently. We’re going to take a closer look to see if it’s specific to 6.1  (which at first glance, it appears to be) to see what’s causing this.

@TabloSupport, the first issue I mentioned was in the previous Roku firmware also :wink:

So how do you change the sort order for the recordings?  I can’t find where to do it.  Thanks.

When you select Recordings on the Roku, it lists 4 sort options.  Genre (popular), Most Recent, Genre (A-Z), and Title (A-Z).

Just highlight the one you want to use.

When I select recordings on the Roku Stick, it shows no such options it just says “No Recordings” when I select recordings with no chance to change the options.

@acronym3 did it get updated to 6.1 recently?? Might want to open a ticket with @TabloSupport and see if they can help more on this, what @snowcat described is how I get to the different sorts on my Roku 3