Roku Stick Not Finding Tablo

My 3 Roku 3’s have no problem with the Tablo, but the Roku stick cannot find it. Any suggestions?

Are the Roku 3s connected via WiFi too?

No, just the stick. But everything else works on it.

If you can plug in an extender to the Roku stick (a short HDMI cable that allows the Stick to dangle on the side of the TV), it will likely help in your situation.

Can you please try one of the Roku 3s on WiFi? Sometimes, a feature called AP Isolation is Enabled on certain routers which separate the wired network and wireless network.

I had a problem with some of my Roku devices as well, including my Roku sticks. Worked with Tablo support for a while, and had the impression that this problem exists with a small percentage of Rokus. Eventually, I moved my Tablo to an Ethernet port right off my router and that solved the problem on every one of my Roku devices. If your Tablo is on wi-fi and you can move it to an Ethernet port, give that a try and see if it solves your problem. Incidentally, all my Roku devices worked with Tablo if I used the original Roku app. It was only the new Preview channel that had this issue.

Tablo is connected by wire directly to the router. AP isolation is not enabled. I have a FireTV stick I just bought and will try that later this week. Thanks

@beyond2k Are the Roku 3’s that are working correctly connected via Ethernet? If they are, try removing Ethernet and putting them on Wi-Fi. Do they have the same issue?

I already asked the OP that as they said only the Stick was WiFi. I assume they tried the Roku 3 WiFi if they didn’t respond directly to my question.

I am also having trouble with the Tablo Preview Channel on the Roku Stick (HDMI) not finding my Tablo. It says No devices were found - No Tablo was found on your network.
Please note: The regular Tablo Channel on the Roku Stick (HDMI) finds my Tablo.

My Roku Stick (MHL) on another television has no problem finding my Tablo on either channel. Same goes for my Roku 3 (WIFI) and my Roku 2 XS (wired). The devices all have the same version (6.2) but different build numbers.

I’m not overly concerned because I can use the regular Tablo channel but I wanted to share since it seems like the problem could be specific to the Roku Stick (HDMI) and the Preview channel.


Interesting - so the Roku Stick you’re having problems with is the 3500 model?

The MHL Stick is 3400.


Your Stick, is it the 3400 or 3500 model?

The Roku Stick that I am having problems with is the 3500X - Roku Stick Version 6.2 - Build 3491.

All the others are good.