Roku no longer finds 4-tuner Tablo

I have a Roku 4630x Premiere+ and it no longer connects to my 4-tuner Tablo. I’ve had both for four months with no issues. It worked with Tablo firmware ver 16 and 18. Then last week it could no longer connect.
I have reverted back to firmware 16 and reset the router, Tablo and Roku (in that order) multiple times. No joy.
I have even tried going “back” to firmware 18, reset everything and still no connection.
Please Help!

Do you get some kind of error message when you open the Tablo app, or when you try to connect to the Tablo from your Roku? What exactly shows up on the screen on your end?

I think it works now!
I see the “Connect to tablo” screen and it appeared that the only option was “search again”. I didn’t think to try and click on the “Tablo” button as it was not highlighted. I can’t believe I spent the last 10 days trying to figure this out. ;-O
Thanks!

1 Like

Holy mother of Batman.
I just realized ‘Tablo’ is the name of every Tablo by default.
I would have been stunted, too, if I hadn’t renamed mine.

2 Likes

Excellent tip! I just renamed mine as well. Thanks!

1 Like