Roku frequently “loses” Tablo app

Anybody have an answer for this?

The app has gotten so buggy that it has to be deleted and then added back on to Roku in order to work. This is happening with both my Roku 3 and 4 boxes. It’s gotten to the point where we keep the Tablo app at the bottom of the app screen because we’re deleting and reinstalling the app every day, sometimes more than a few times.

What does “buggy” mean?

I have Roku 3’s (4200) and Roku 2’s (4210) and don’t have any problems.

Rokus do eventually die. The Roku 3 is 5 years old.

It also has limited memory. The tablo app has to have some place to store all the guide and recording data. Therefore I only keep 23 Roku channels on my device.

1 Like

I have three different Rokus, and no issues at all with the Tablo or the Tablo beta app.

We still use a Roku 3 (4200X) and haven’t experienced the issue you have. Have you checked to see what Channel Version (Tablo) you are on? Should be 2.8.0 (on the 3).

I would also check your Roku power adaptor.

Buggy is the word I’m using to describe the frequency with which I have to delete and reinstall the Tablo App on both my Roku 3 AND 4. The fact that you have an older Roku box with no issues seems to indicate that age probably isn’t the issue.

Everything is up to date as far as the Roku software as well as the Tablo software. I always make sure to stay current.

I’ll check that, but I doubt that is the cause. Two separate Roku boxes in different parts of the house with the same issue? It doesn’t seem like it would be the power adapters, but I’ll check it just in case.

1 Like

I’ve skimmed some of the boards here and have seen similar issues mentioned, that’s how I knew how to “fix” the problem by trashing and then reinstalling the app. I haven’t seen any workable solutions to this problem.

1 Like

I haven’t tried posting this issue on the Roku boards yet. I’ll check over there to see if can find an answer. If I do, I’ll post it here.

1 Like

What kind of symptom leads you to reinstalling the app itself? What kind of behaviour do you see in the app that leads you to the reinstall? Do you get an error message, failure to connect, etc?

The app can be functioning normally. When we disconnect to watch something on Netflix or Amazon (or just disconnect it before going out) when we try to connect with Tablo again, the app can’t find it. Pressing the search function is useless. That’s when we have to delete it and reinstall it. It’s the same problem for the Roku 3 and 4 we have. All of the updates for Roku and Tablo have been applied. Once we reinstall the app and run it, it functions normally…until the next time.

It’s not necessary to use disconnect at any time, unless you have multiple Tablo DVRs on your network. You don’t even need to close the app as there’s no danger that the app can suck data in the background, especially on your local network.

Over the next few days, instead of hitting disconnect can you try to remember to just hit the HOME button and go to whatever next app you want to navigate to?

The real question is why your Tablo isn’t available when you go back. This is usually due to an issue on the home network. It’s likely that @TabloSupport will want to take a closer look at your network and your Tablo to learn more about that part of the puzzle.

Actually, pressing the home button is how we disconnect, especially when we want to watch something on Netflix or Amazon Prime.

You mentioned the in home network. When this problem first started happening, we would restart the router, that would work, but it took a long time to get back online. When I saw people mention deleting the app and reinstalling it, that took far less time, but it was only a temporary solution that seems to be getting worse.

What about just rebooting the Roku? Instead of deleting the app and re-installing.

I’ve tried that a few times. It doesn’t work for me.

Also which Roku 3? Model 4200? Or an older one?

I don’t think the user has even identified what Roku OS release is installed.

Roku OS 9.0.0.4084 has been slowly rolling out to the Roku 3 devices.

Software 9.0.0 • Build 4084-04 on my Roku 3

Software 9.0.0 • Build 4084-17 on my Roku 4

I have the Roku 3 - 4200X.

Keep in mind that I have a Roku 4 as well. I’m having this issue on both boxes.