Roku cannot locate tablo but other devices can

My Roku gives me the cannot connect to tablo error. Other devices on my home LAN can use the tablo just fine (macbook, iphone, ipad – all wirelessly). The Roku and tablo have a wired connection to my single router. They are on the same subnet and I can ping both from my macbook. Other apps/channels on the Roku work fine.

I’ve tried rebooting both the Roku and Tablo. I’ve tried reinstalling the Tablo app on the Roku.

Tablo Device: 2.2.10

Is there anymore debugging that I can do? I’m competent with networks.

If you have Roku OS v7.5, that’s the problem, and already reported to Roku, and Tablo.
Otherwise, the router would be the next thing to reboot.

Roku is 7.2 build 4100-04
Model 4210x roku 2

Tablo app on roku 2.1 build 34

Try the Roku on your wireless network.

@paperstaples Definitely give @theuser86’s suggestion a try.
If this doesn’t do the trick, send our support team a ticket.
Also curious: do you get a ‘No Tablo Found’ message, or some other error?