RESOLVED - Fire TV software update - Tablo no longer usable

Thanks for how to tell gen’s… I have 3 gen 2’s ( all have sd slot) for what ever reason 1 of them did not update to , and that one is working great being WIRED with firmware, The other 2 that did upgrade to failed to connect to the TABLO after the Fire TV Firmware was upgraded. On the failing WIRED Fire TV’s the TABLO APP finds my TABLO but fails when trying to connect. I can set “Remote Access” on and they connect in remote mode and the video is degraded. The TABLO APP tells you to turn Remote Access in order to connect to your TABLO. But both WIRED FIRE TV’s connect to the TABLO when the WIRED connection is removed and the Fire TV is configured for a WIFI connection. I also called AMAZON to post a issue …They need to fix this quickly.

Gen 2 here having the non-connect issue. Tablo wireless, Amazon Fire TV hard wire. Also if it matters, Tablo quad tuner.

I now have the same issue. My Fire TV boxes (latest gen) updated to last night and I can no longer connect to my Tablo. Everything is hardwired and I’ve tried every suggested combination of rebooting devices.

My PC, iPad have no issues connecting, just the Fire TVs…

I have this exact same issue. Fire TV Gen 2 hardwired. Was working prior to latest Amazon firmware (5/24 or 5/25) and then not working. Would try to connect for 15 seconds and then loop back to the connect screen. As soon as I disconnected wired ethernet and switched to Wifi, I was able to connect to the Tablo successfully. +1 for issue with Amazon Fire firmware upgrade. Now, what is the best way to go to get Amazon to fix?

Exact same problem on 2nd Gen FTV box. No thumbnails, and recordings that are supposed to be an hour long are 3 minutes. The only difference for me is that so far, I can still connect to my Tablo. I’m too tired tonight to mess with switching to wifi. Probably won’t try it until the weekend. I’m so over the every-few-months-a-new-problem. :frowning:

This is what I just sent to Tablo Support:

I unplugged the network cable from the Fire TV 2 and connected via Wifi. The problems went away. I was able to connect easily and my recordings loaded and fast forwarding and rewinding worked correctly with thumbnails. So this is good.

I plugged the network cable back in to the Fire TV 2 and I have no problems connecting. But the problems with fast forward and rewinding and missing thumbnails is present again. This is bad.

I don’t want to be on Wifi, I want to be hardwired.

So Amazon broke something. As a certified app developer for the Fire TV’s, will you be reaching out directly to Amazon on this matter? I see that more people are starting to experience this as their Fire TV’s get the update.

No issues for me on my Gen 1 AFTV’s (I have 2 of them and one stick).

I also have this issue as of this morning. Brand new fire tv (4k version). Went to load the tablo app this morning and i get connection failed.
I cleared cached, data, deleted the tablo, uninstalled and re-installed. Now i don’t even get the connection failed message, it just says connectiong, then the cancel button shows up for a few seconds, then it goes back to the tablo selection screen.

Works fine on my android phone.

Anyone know how to block FireOS update until this is sorted out? I am still on an older version.

Here’s a link to an article from a very reputable site on how to block updates. I have not, nor do I plan to do this.


Have you tried unplugging the network cable from the Fire TV and instead using Wifi? This is working for me while we wait to get a fix.

p.s. I blame Amazon, not Tablo. I’ve been extremely happy with Tablo since I got it in January.

Thanks. I switched over to WIFI and the tablo app now works. Hopefully somebody fixes this soon. I’ve had nothing but bad luck with this thing so far. Pretty odd that it works over WIFI but not Ethernet.

I too am having the issue. I can connect without issue through the Android app and the iOS app. Just can’t connect with the Amazon Fire 4k box. I have rebooted both devices, uninstalled the Tablo app, etc.

Hi folks -

We are aware of the Ethernet connectivity issues affecting Amazon Fire TV generation 2 boxes running Amazon firmware We have managed to reproduce the issue.

The temporary fix seems to be to switch the Amazon Fire TV to WiFi connectivity.

When we have more details on a permanent workaround or fix we’ll be sure to let all of you know.

In an effort to expedite a fix for this, please place a ticket with Amazon support with as much detail as you can provide:

NOTE: If you’re unsure as to whether your Amazon Fire TV device is a generation 2, look on the back for the MICRO SD slot as shown here:

@djc6 I’ve used this guide on my aftv 2nd Gen and method 2 via adb works well without the need to root. I blocked my software updates after version blocked Firestarter and am still currently on v5.0.5.1. You can unblock the updates at any time.

Interesting. I submitted a support ticket to Amazon. Their reply was that this is Tablo’s problem. :thumbsdown:

I just got off the phone with amazon support, I hadn’t even seen the post from TabloTV yet. I explained all the information from this discussion, latest update, wired connection and not WiFi, and only gen 2 devices. The support tech tried to escalate me to the next level and he was refused and told Amazon’s policy it if an app has problems after a software update, then the app developer will need to fix it. Not very helpful. I’ll switch over to WiFi for now. Thanks. Looking forward to a complete solution soon.

I got the run around the first time I complained to Amazon about this problem. I did call back and talk to another first and then second tier support tech. I gave them their step by step trouble shooting solution right back to them verbally. That is when they patched me through their second tier help desk. They only thing he could think of was reloading the firmware to fix the problem. I told him it would be like throwing the baby out with the bath water because the wash cloth fell into the water.
They only have two tiers before you go to a developer with a trouble shooting ticket. I guess Michial (sp) submitted the ticket. He and I both agreed that it was an Amazon firmware issue. I have not heard from then yet. I am hoping to hear from them soon. I don’t know why they would have a problem working a problem they caused. Everybody has bugs after a new firmware release. I don’t know of anybody who hasn’t. At least it is not as bad as the Windows XP SP1 to SP2 upgrade in 2001? Now that was a fiasco!

Per Tablo Supports request, I submitted a trouble ticket via email to amazon. Everyone should. Here’s the link:

My tablo was taking for ever to tune in a channel. Once it did, the picture was horrible.

I found this thread, saw that my fire tv box gen 2 was updated (thanks Amazon for not asking before updating).

I can concur that unplugging the wired Ethernet resolves the issue.