Remote Access broke again!

I’m not so sure about that…because if you saw the rest of my posts from last night, you’d also have seen that the device refused to update from 2.2.2. Even their support could not get to my device in heartbeat mode, although they have in the past. Then this past weekend I found I could no longer access my Tablo via web browser. So I tried to get here - and I found I wasn’t able to access any Tablo site - either just the Tablo main web site or the community.tablotv site- browsers of all flavors said unavailable!
I could ping my Tablo device, I could enter its IP into a browser and get the default Tablo server message, so it was accessible. But for some weird reason the device wasn’t accessible and neither were their web sites. I found it was something to do with the word tablo itself! Facebook, other sites where they post officially, could not get to anything Tablo.
Then for kicks we decided to watch a show I’d recorded last week - I warned my wife that since I had no access to the device, it may not work with the FireTV stick either- but it did! We watched the show, I found the FireTV stick tablo app update made some changes I found weird but finally ok, it was something trying to figure out how to do certain things again but over-all it worked fine.
She went to sleep, I stayed up and figured what the #$% since the FireTv app worked fine with my Tablo, the whole issue was with web access. I got to the Tablo settings in FireTv. I tried again in a browser. Still no joy, still unable to get HERE.
I had already rebooted the Tablo AND the router multiple times.
The FireTV stick had full access so I tried the update option again - it has failed for weeks, didn’t matter what I did or how, the bloody device would never update. Another had the same problem. I contacted support, they were baffled.
They released 2.2.7 for me, that even FAILED all last week, every single day it failed. And to get Tablo back I had to hard boot it.
Well I tried the upgrade with the FireTV stick and wow!! It was working!
What the… why? Huh? I saw it hit 100%, it applied and in a blink it was rebooted.
And as quick as that upgrade applied and Tablo rebooted, NOT my router, but Tablo itself rebooted, I had full access to this site! I had full access to the Tablo device from my browsers.
The ONLY and I mean seriously ONLY change was Tablo updated, Tablo rebooted, and my browsers worked again.
So, the Tablo DEVICE itself, the IP stack was messing with my LAN communications.
That is the one and only thing it could possibly be. That’s all that changed. All week, actually the last TWO weeks, Tablo refused to update. Tablo did not let support in from Tablo the company, and finally this weekend I lost all access to Tablo and the tablo sites.
Tablo updated, Tablo rebooted, not a cat’s whisker was changed otherwise and suddenly I could get to Tablo and I could get to their web site again!
Can’t tell me it wasn’t the Tablo IP stack messing with things.

OK, my point number 2 is this - for several days while messing with the device I noticed that the “remote ports” reported in settings were no longer 3 but 2. I noted that while since Hector was a pup two of them had been 21100 and 21101 that suddenly Tablo was reporting the 2 ports were 23100 and 23101!!!
I am dead serious. Like magic they changed in the Tablo settings page - and my router’s UPNP also showed the change! Yes, my router had the different ports registered in the UPNP as 23100 and not 21100 and 23101 instead of 21101.
So why did Tablo change those ports in the Tablo settings page - and also configure my router so that it had those 2310x ports instead of the 2110x ports that it has had for MONTHS since I got the thing?
Funny thing - after the update of Tablo and reboot, it’s back to 2110x instead of 2310x

So, explain how Tablo was blocking access to all things Tablo until after it updated and how the ports it wanted to use changed all by themselves?
Yes, Tablo has a flaky IP stack, plain and simple.
It’s not the router - no one will ever convince me that two routers in the past year have been a problem when I have zero other issues.
All other apps, games, whatever, work fine. Nothing else on my network fails ever. I’ve never had to reboot a router at home except to try to get Tablo to work.
So I say that their IP stack is funky and it messes with some routers while it works ok with others just like Intel and 3Com network equipment used to kick at each other like kids in a sandbox in the 1990s.
Their IP stack is flaky.

Oh, hey - forgot one other thing - several folks last year found that the ports Tablo uses are sometime reserved by ISPs as being for SSL… so their devices were having trouble with remote access, too. They said something about changing the ports FROM the 21100 and 21101 to something different then it worked.
There’s no place to make such changes that I can see. Somehow they did it, though.
Apparently THEIR Tablo devices originally came configured with some higher port number settings and it worked until some update changed things to the 21100, etc. and when they put it back remote access worked again. Their ISP was AT&T if I recall…

It won’t take a whole lot for me to use wireshark or similar to prove the router port forwarding is working… but after the fiasco of the last two weeks, especially the last couple of days, I don’t trust the IP stack of the Tablo itself as my network has always been fine, router works. ONLY Tablo has ever had issues. Tablo wasn’t able to update then suddenly does? Tablo can’t be accessed, the after an update it can be? Can’t get to this web site here then after Tablo reboots I can? Uh, without rebooting my router or PC or closing my browsers? Yeah, right, it’s the router for sure.
Updating and rebooting a totally different device and at that exact instant, and I mean the exact moment tablo rebooted and came back things now work (*except for remote access) so we blame the router?

@ShadowsPapa - The support team would be happy to take another look at what’s happening with your Tablo and router. Just drop us a line:

Hi All,

I found a work around to remote access if you have Plex, but not using the Tablo Plex App, which seems buggy and slow, but a better way by using the tablo ripper.

Basically (using Teamviewer or RDP to reach my Plex server) I rip any shows I want to watch to my Plex server and then simply connect to my plex server. Works great and easy to control the quality.

This whole remote access problem has been painful for a while, but at least this has been very reliable for me.

I’ve used remote access a few times, but not with much luck and not reliable at all. I’m surprised this remote access method has even been released as a working product due to how buggy it is…at least for me.

Bad that I have to use this work around, but at least it works very well.

1 Like

Happens with nothing changing, too. Worked for 5 minutes remotely, on second connect, it was down for the entire weekend until I got home. WAN IP the same, no other issues on network, ports already forwarded, etc.

Just typical Tablo poor quality.

If it matters, I had the exact same thing happen this week. Watched a few minutes of the Eagles / Lions game to make sure everything was fine. 10 minutes later, tried to get on to record the Cowboys game so I could watch it if needed - couldn’t connect. Mine stayed down all weekend until I just got home. Verified no WAN IP Change, verified no power outage while I was gone, verified port forwards still in place in router - had to reset the tablo to get it working again.

It’s simply the garbage quality of this garbage product - no matter what anyone says.

It’s easy to blame Tablo. Since it’s a Tablo problem… more Tablo problems.

I too have a remote access issue since day 1 of owning Tablo, a 12+ month issue. Tried several different routers with and without IP / MAC reservations, UPnP, port forwarding / triggering, etc.
Works for days / weeks then fails, presumably due to ISP dynamic IP change.

HOWEVER…I have 4 other remote access devices, a Nest Thermostat, several MegaTec IP controlled power outlets, a surveillance IP camera, and a Logitech iPeng music server. NONE OF THESE lose their connections. They do require a login/password but no other ‘pairing’ vudu… They JUST WORK, and some have been here working for YEARS.

Nest took a long time blaming the issue on user routers, and issued an 'approved router list" after blaming the customer. Many forum complaints from people buying a replacement router who then came back to the Nest forum saying: “I’ve replaced the router and it still does not stay connected!”.

Thankfully, they figured it out and fixed it, but it caused early adopters for over 1 year to not have a key feature, remote access…

Change of Nest ownership and staff made the difference after Google bought Nest.

Tablo is my only remote access device (of a total of 3 outlets, 1 Nest, 1 camera, and 1 music server) which does not work reliably.


Well, finally back home. Took a look around, no problems with anything (router, Internet, Tablo) except that the remote access did not work after I left (and as per original post, I had tested just before leaving). I do have Tablo asking to update to 2.2.8, but it has not been done yet.

So … Remote access worked, then with no change on any of the typical fronts, it stopped. Once I got back, I was able to re-establish remote access, but of course, that’s garbage if it stops for “no reason” and I have to travel back home to re-establish.

@TabloTV this needs to be removed from the “Features” list to a “Futures” list…

I already started a thread. Same problem here.

I would love to work at Tablo, I could make tons of mistakes, release software to clients and no one cares.

I use Tablo Remote all the time on trips to many different locations. The only diffiulty I have ever had is with certain firewalls (including employee work network but not guest work network). Tablo Remote has never “disconnected” after firware upgrades or for any other reason. For me, it has been a “feature” - and a very dependable one. I look forward to other Tablo remote alternatives that will allow others who have not had success with Tablo Remote to enjoy its features.

1 Like

That saying acronym “YMMV” is so very true when it comes to Tablo and it’s users…


1 Like

Variability in user experience seems to confound so many Tablo issues. Some of us have issues A and B but others do not, yet no problems with issues C or D. Others don’t experience A or B yet seem to suffer C or D. YMMV indeed !

For whatever it is worth, my remote access works quite well when it works, and this is for days or weeks. My only remote connection complaint is a sudden loss of access, only correctable by re-pairing while within my LAN. Not cool for travelers…

Timeline scrubbing and sync between player and Tablo is sometimes flakey remotely, but is livable. Latency from my cellphone carrier / Internet is a problem for streamers including Tablo so I grin and bear it.


If I “needed” remote access, I would be upset – Haven’t had it for at least a couple months or more to my office computer. But, as you and most others here already know, I have Tablo Ripper, MCEBuddy and PLEX so I really have very little need for anything remote other then PLEX and as they say, “It just works”.


1 Like

unfortunately, this is not in their marketing materials.

@adam … not sure what you are responding to exactly, but remote access is still on the front page of … about 1/2 way down …

Enjoy HDTV Anywhere
A Whole-Home-DVR, Tablo lets you stream live and recorded OTA HDTV content to as many as 6 devices on your local network. Or if you’re on the go, you can stream live and recorded programs over WiFi or 3/4G wireless connections. More >

I haven’t tried remote access in a while but when I did it worked fine. However it was kinda slow to respond but maybe mc donalds wifi was kinda weak. :blush: I checked my virtual server settings in my router and they are setup for ports 21040 and 21042.

@mohoelx sorry - whatever I was responding to meant to imply that it not working is not present in their advertising materials. I have the problem, as well. If I ever post something in support ot Tablo doing something right, it will be in bold font, with a yellow background, with pictures of pigs flying in the background - and I’ll by typing it from the firey pits of hell while swilling on a tall glass of ice water.

That’s an interesting scenario. The other place is serving Gin and Tonic on cloud nine. Sorry for the non contributing bit, could not resist.

I was not talking about WAN. I was talking about my tablo changing ip setting on it own (lan).
I finally think i figured it out… You have to lock it with setting on your router…

Thanks Tablo for telling me… (not)

DHCP Reservation is an advanced feature on the Linksys Wi-Fi Router. It is especially useful when you are setting up a computer as well as wired or wireless network devices such as printers, network storage, gaming device, or server computers that you want to have access using a specific IP Address.