Reformat external WD hard drive

My external hard drive failed and I bought a new one for my Four-Tuner Tablo. I cannot find any help with any real clear instructions on how to do that —help that works. I have unplugged the Tablo, removed the old hard drive, plugged in the new hard drive, plugged in Tablo, but never do I get an option of formatting the new hard drive. I have pushed the blue button in the back, but all it does is turn off the Tablo and turn it back on – no formatting options. Where it should say the name of the hard drive it just says that I need to format it. I use Apple TV and use wifi – no ethernet for the Tablo. Please, step by step instructions. Thank you!! I have been dealing with Tablo issues for over two weeks. It is getting really old – making me think that paying big bills to cable or satellite companies was not so bad. That is how frustrated I am.

Use a web browser (Chrome works well) and go to You should be able to format it from there.

I plugged the new hard drive into my laptop and the Tablo site tells me no storage unit. No option given to format.

1 Like

If you are using Windows, open “Disk Management” and remove any partitions on the drive you want to use with your Tablo. Be careful not to remove any partitions you use on your laptop. The format option should be available when you reconnect it to your Tablo.

Leave it plugged into the Tablo. Use the web app on your computer to connect to the Tablo. Then you’ll get the format option.

Tablo is on, new hard drive attached, on my laptop looking at Tablo and get message
" WD My Passport 260D 2003 (2000 GB) Storage temporarily unavailable

Never mind – got it figured out.

1 Like

You need to power down the Tablo. Wait 30 seconds and then power it up. You should then see the option to format your hard drive.

How did you figure it out? This thread will be helpful to others with the same problem.

It’s probably documented somewhere. I first tried a warm reboot (hit the blue reset button) and when that didn’t work, figured I’d try a full power down / power up sequence. Turned out that did the trick. Not sure if I remembered reading it somewhere long ago, or if I just tried it because it made sense to me.

I’m asking a similar question: Tablo Dual Lite - need steps, replacing hard drive

Second the need for better documentation on this.

Thanks for the update! Helped me, as I was also stuck.

I’ll add that going to the website from my phone didn’t give me any prompt. Even though I had done a done a full power cycle as part of installing the drive, had to do another full power cycle and log in to the site on a PC again to get the format prompt.

There should really be a button for this.

1 Like

As well as an option for reboot. Me, I have absolute control over my tablo, for a multi-user household - a format with no security it’s extremely dangerous.

You say “log in to the site on a PC” but did you really log in? with any user/pass or credentials? If anyone can “accidentally” format a drive at will…

I do agree though, seems too many users run into issues trying to format their drives.

When I become World Emperor. Posts like this will be a hanging offense.
Seriously, many people are having this problem, including you, and people coming from Google. You figure it out. Why did you even bother to log in JUST to say “figured it out” with NO other information?

The mind boggles

Thanks for posting that, I was freaking out that I had a bad drive…powered down, installed the internal SATA and powered back on, it recognized the drive, but wasn’t available. 2 times power down, wait at least 30 seconds, power back on and formatting came up - it came up on my iphone app, so it doesn’t necessarily have to be a browser window.
This was replacing a 5 year old external drive I was using, I hope this fixes the buffering issues from live TV.