Reduced image breakup with router change


#1

Just FYI… I don’t know if this will help anyone else or not.

I’ve been having a lot of trouble with image break-up when watching on my Roku. Technically speaking, occasionally a GOP will have a number of macroblocks that seem to be based on the forward picture when they should be using the prior picture. Non-technically speaking, things will suddenly go wonky right around something in the scene that’s about to move, it all clears up in half a second, and oddly the wonkiness appears to be little bits of the image that show what they’re going to look like by the time it clears up.

There are many places that this sort of thing could be introduced. The station could be transmitting the picture that way… where I live, ABC 720p and CBS 1030i are crammed into a single transmitting channel along with an SD subchannel, and that’s more compression than normally recommended for HD broadcast. Of course, the Tablo may be getting a weak signal from the antenna, causing some data loss. Something could go wrong inside the Tablo tuner in the transcoding to H.264. During playback, data packets could be lost between the Tablo and the router, and between the router and the playback device.

In my case, it appears that a substantial portion of the problems were occurring on playback. I made a small change in my Linksys EA6300 router that has reduced the rate of motion break-ups to maybe 1/3 what it was, and the ones that remain seem to be the less harsh ones. Specifically, on the Media Prioritization page, I set the Tablo as top priority (mine is hardwired Ethernet), and my Roku 4 as second priority (mine is WiFi 5 aka 802.11ac).

I don’t know what contention there could have been for data bandwidth at my router. I can’t think of anything else that would be doing significant router access while I’m watching TV, which is why I’d never thought of setting priorities. But that change does seem to have made a big difference for me.


#2

Depending on who else might concurrently be accessing the tablo, why wouldn’t the Roku be prioritized over the tablo. If the Roku was waiting on the tablo it would be asleep and not consuming band width.

Normally the tablo would be pumping data to the Roku. It would seem you would want the Roku to wake up as soon as the router has data from the tablo.

But the router LAN bandwidth is disappearing somewhere or it’s a really crappy router.


#3

Considering overall speed of a wired network, it shouldn’t really be bottlenecked? On a router, wired priority vs wireless priority intermixed? Wifi 5GHz could be A, N, AC or a mix of any all?


#4

If it is truly caused by wired priority maybe the router port or cat5e cable is going bad. Of course many linksys routers done have a traffic meter.