Recordings won't play

You guys downgraded my firmware which solved an issue with a single channel playback pixelation, etc. that was blamed on poor signal; however, now I can not watch any recordings that were recorded during the time the system was at the newer firmware. Is there any way I can edit the database to allow these to play? It’s not like these shows magically air again to where I can just re-record. If I go back to 2.2.12, then I have to deal with the crappy playback/recording issue on NBC. Starting to get disappointed. TV is literally just supposed to work, not be work.

Also, can I get logs from the unit at all? I would hate to have to submit a ticket for every random restart if I can look at what may have caused the restart myself. I do this stuff for a living literally.

I also can not export the recordings from the old firmware using any of the tools that call the API/Rest interface.

I did most of my early testing with what became SurLaTablo 2.0 using the older 2.2.10 firmware, it should work (I think).

Nil, can’t pull recordings that were made for 2.2.12. Tablo support folks, am I screwed here?

Sorry to tell you mate, but if you are getting pixelation then your signal is on the dodgy side and you need to do something to improve it. Once you do that, you will be much happier. This was my experience - I got a new antenna and had it mounted properly and my recordings are all much better now.

From what I can deduce, a internal database conversion takes place when going from 2.2.10 to 2.2.12. So, the idea of rolling back to 2.2.10 doesn’t make a lot of sense. It doesn’t surprise me that you can’t look at 2.2.12 made recording while using the old firmware.

So here’s the deal bud. I have a proper antenna. The signal was/is not the issue. My antenna is properly attic mounted, pointed towards the towers with no obstruction at sea level and is run off about 10-12 feet of RG-6 coax to the tuners. There are multiple other stations that broadcast off the same tower as well as two other sub stations from the same broadcast that had zero issues. When you attached the antenna directly to the television tuner it also had zero issues. This was only seen through the Tablo.

Oh and guess what, they downgraded to 2.2.10 and the issue went away. And on top of that I got tired of not being able to export or watch the recordings, so I re-updated to 2.2.12 last night with full intention to just have them re-downgrade me after I pulled the recordings off. The problem doesn’t exist on this install of 2.2.12 anymore. At the end of the day the software is on the “dodgy side.”

Ok, then I contend these shouldn’t be called 2.2.10 and 2.2.12, it should be considered a major release change and they should have a good look at semantic versioning.

A horse by any other name may not be a horse.

I went down this same rabbit hole. While testing the latest firmware I got pixelated channels on stations that were perfect on the previous version and perfect when directly connected to a spare TV.

The pixelation would spread to all channels until a reboot, which would temporarily fix the problems. I opened a support ticket where my router was blamed and then my hard drive. In my current setup, everything is wired, no wireless, to a high end gigabit switch, so my router doesn’t even come into play. And I’ve swapped and reformatted different hard drives in the name of testing with no difference. After that, support offered to downgrade my firmware, which fixed my pixelation issues but led to several recordings being unusable.

I had to switch back to .12 to satisfy the wife who wanted her shows. So now I reboot the Tablo daily to keep it from going crazy until they decide to release new firmware.

Did they find the bug / issue causing your problem? I would only assume a fix is coming if they did.

No. I was expecting some deep debugging and actual troubleshooting - I do this sort of thing on a daily basis in my real job. But no, they just offered to downgrade me and said they had the logs to look at.

This was after blaming everything else BUT the firmware. Anyone not as stubborn or tech savvy would probably have bought a new antenna, router, or hard drive then been angry when it didn’t fix the issue.

If a fix is coming, great, but I’ll believe it when I see a new beta in place with some acknowledgement that there is an issue.

Oh man, great to hear. This pretty much describes my issue to a T with one exception being that the degradation only happens on a single channel, but yes I also go through periods where reboots seem to resolve it temporarily and it’s worse over time.

They also blamed my antenna, the network, potential hard drive issues, poor signal, etc. Everything is wired in my setup as well; same deal, enterprise-grade network hardware, not your typical house crap as I also work for a software startup doing infrastructure. I am pretty sure I went through all the same troubleshooting steps you did, I would love to be able to get the logs myself to view, but I know that’s just wishful thinking.

I guess I can keep rebooting the Tablo if I see the issue start to happen and continue just hoping for a fix. Honestly I hope this market segment expands after CES with Tivo, at a minimum it will force them to put out a better product or lose customers. The downside is that folks like me, bought the hardware and bought a lifetime guide subscription since I’ve had it for a year+ at this point, and as such we’re a non-revenue generating customer. In the end, they’re not going to care.

Have you tried doing a factory reset?

I did that as part of the troubleshooting process, no change.

I’m curious if you notice anything particularly unique about that channel, that their firmware is not handling properly. Things such as: it’s vhf while all others are UHF, number of sub-channels, broadcast resolution (e.g. 720p), the interleaved guide info, distance from transmission tower (closer or farther), etc.

So this particular station is 1 of 3 that broadcast in 1080i, it’s UHF (all but one of the stations is UHF that I get), and it shares a tower with 3 other stations for a total of 10 channels/subchannels. Only this particular channel seems to have issues. I discussed back and forth with the engineers at the particular station to see if there were any indications as to what could be going on but as I said, this wasn’t/isn’t happening on 2.2.10 and doesn’t occur on a local TV tuner when the antenna is directly connected.

And thanks for the troll. Once again I get a “power user” in the forum that jumps direct to factory reset. Glad to hear people are factory resetting their Tablo units on a regular basis here and no one actually wants to record and watch things some time further in the future.

Would be more than willing to try this suggestion, if Tablo provided a tool to actually reconnect a hard drive with DVR’d shows up to a newly reset unit without having to format and lose the data on the drive. That being said, I’m so tired of hearing “factory reset” that just to appease the trolls I’m going to finish watching recordings on there before Sunday and do this before then. I suspect as @huckabeec saw though, it will make no difference.