Quirky resume functionality

I did a few tests with the resume functionality last night.  Here are some things that worked and didn’t work.

Scenario 1: Started playing recording on Roku 3.  Stopped playback and exited app.  Went back in and was allowed to start back where I left off.   (Note, just stopping playback creates the save point).

Scenario 2: Stated playing recording on Chrome browser on PC.  Stopped and went to the Tablo on my iPad.  I was able to start that recording at the save point.

Scenario 3: On the Roku 3, I went to the recording used in scenario 2.  It started at the beginning and not at the last save point.    I played it a while and exited.  It would not create a save point on the Roku, so it always restarted to the beginning.

Scenario 4: On my Android phone running Tablo Connect remotely, unable to skip ahead on any recording, and all start at the beginning.

Last night while watching Blacklist, our Tablo exited out of the playback window.  It wasn’t a full Tablo crash, but playback randomly stopped and exited.  Entering back into the recording resulted in the recording starting from the beginning.  I’m assuming behind the scenes, a save point is created when the user hits the back arrow or otherwise intentionally stops recording.  Since the recording exited on it’s own, neither of these actions were taken.

A nice feature would be to automatically add a save point every minute or so, that way when Tablo crashes, you will still be pretty close to where you left off.  I suppose a better feature would be to reduce the number of mini crashes because it seems to happen to us once every two hour-long playback sessions.

Last night’s setup:  3rd generation iPad, using airplay to send to appletv 

@snowcat - In scenario 3, did you not see a ‘Resume From’ option in the menu?

And in scenario 4 - when using Tablo Connect it will always start at the beginning. 

@bwbouzarth - Send a ticket to @TabloSupport re: your playback issues. Might be the ATV that needs a firmware update/reboot… 

On android phone (4.1.2) a new step is present within the web app, when playing a video a new screen and button to “Launch Video Player” is forced.

Using an external video player means the “resume” feature and “watched” indicators don’t work for videos consumed on both the android phone and tablet platform. At the least, the watched indicator should be tracked from android phone… @mattb33 just mark the video watched once launched. Why have a partially watched indicator if you can’t even track it on both the android phone and tablet platform, when an external player is used!?

Better yet, make it work along with the resume feature.

In scenario 3, I didn’t see the resume from playback that I did in scenario 1.   I went to another untouched episode, and it the resume worked fine.  It was only a problem with watching a show that had been watched on another device (it also happened this morning with another show).

And in scenario 4 - when using Tablo Connect it will always start at the beginning.

Come on Tablo, test and release a new feature across the product experience. I can’t think of a reason (other than Dev-hours) for the resume feature to be missing from Tablo connect. I would have expected it to work on Tablo connect. The purpose of the new feature and how the release notes are written strongly suggest this is a great new feature that I would want to work across my full Tablo experience. Oh well.

Next time, keep it in beta until it’s finalized across the Tablo experience. This stop and go, works here but not here, experience is tiring and leads a highly disjointed use experience. Plus, I’m sure your beta testers would help point out where shorting the Dev hours just won’t fit expectations.

@snowcat… I’m wondering if that page isn’t refreshing fast enough for you. We’ll check it out.

I can confirm the refresh has delay. It would sometimes take the Roku 3 up to 10 seconds to display the resume menu option.

Both Roku and tablo hard wired.

I just got home from work, and it appears to be much better.  I had been watching a show on my PC this morning, and when I tried to play it on the Roku, it had the proper save point.  I then watched another show on the Roku, stopped it, and when I went to my PC to watch more, it had the proper save point.

So it may just be a timing issue between devices, where it won’t immediately sync correctly, but it will after a short delay.

@snowcat - Glad it’s working better. Our Roku dev is looking at reducing the amount of time between save points which may help as well. 

I have noticed when I start watching a show from the IPad, and try and resume from the Roku it will always play from the beginning. It does not shoe the menu option to resume. If you try and force it from Roku by watching a little bit of the show and exit out, the screen will flicker slightly but never show the resume menu option. They only way I get the resume to show up in Roku, is if the Roku was the client to start watching the show. Then it will work after waiting a few seconds to sync. Also the new resume feature is causing button click delays. If we move faster than the sync time after exiting a show, the buttons clicks are delayed.

@guck11 Hm - interesting. What model of the Roku are you using? And how long are you waiting between switching from one device to the next?

I am using Roku 3. From the iPad i am waiting a long time before accessing on the Roku and the resume will not show up on Roku. When I initiate a first time play on recordings from the Roku 3 I am fine and it will show the resume. How however with a delay of up to 10 seconds. Usually aroun 1-2 sec though. Everything is hard wired

@guck11 Thanks for all the details - we’ll create some test cases around this in the office to see if we can reproduce.