Not getting prompt to format hard drive

I have a 1TB Toshiba Canvio hard drive. USB 3.0, backward compatible.

I set up the Tablo, but never received an option to format the drive. Now, in the status, it just says “unformatted storage.” I’ve reset it and unplugged it, yet never get any option to format.

Any help would be much appreciated!!

What device are you using to setup the Tablo? Try website in the Chrome browser on a computer.

Thanks for the quick reply. I’m using exactly that - with Chrome. No luck. Any other ideas? Do I need to reset and start over somehow?

If you have a Windows PC then connect your drive to the Windows PC and open “Disk Management” and remove any volumes/partitions on the drive you want to use with your Tablo. Do not add any new volume/partitions or format the drive. Be very careful not to remove any volumes/partitions you use on your PC. The format option should be available when you reconnect the drive to your Tablo.

This isn’t platform specific.

Other’s have tried this, if they’re missing something in the process on a fresh drive, this can be pointless. Even if it is formatted (with anything) and not recognized as

format_state	"authorized"

I believe its add a cute dot file for it know it by.

There was this post from someone who re-formatted, and swapped drives, re-formatted needed to slow down and go step by step.

So, I thought I’d provide a follow up. I went to bed last night without a solution. This morning I woke up and the system prompted me to format the drive.

I have no idea why, but apparently it just needed time (a number of hours) to recognize that the drive needed to be formatted.

Seems fine now.

1 Like

You’re not the first who couldn’t get a format message - for what ever reason.

It’s been a year since I’ve done it, without issue, so I don’t recall specifics. But, like you, in the end it turns out not to be complex. I suspect it might have some thing to do with powering devices up one at a time or not connecting them all before everything is “ready”. But, that’s just speculation.

Then there are others who have “real” problems and need to contact tablo support.


Usually, powering down the Tablo, waiting 30 seconds, then powering back up will get you the prompt to format the drive.

If all else fails try this utility and erase the partition table and the boot sector. It’s free to use and has an option you can check to do a quick low level format (erase). After that go directly to the Tablo, Don’t format in Windows or any other OS. Just be sure to choose the Correct drive and not your Windows drive, etc.

Logic here is that the Tablo see’s what appears to be a blank unformatted HDD.

If the tablo doesn’t “see” a drive, with or with out any format, MBR, GPT or connectivity… -illogical

Explain yourself? And what evidence do you have?

If you plug/connect a drive to a computer and it doesn’t acknowledge a device has been attached to it… explain that? Regardless of what format it may or may not have - if the device doesn’t acknowledge hardware has been connected - it has no bearing.

evidence – no hardware connected. I have my evidence - now you get yours :poop:

So you’ve monitored all the traffic going to the drive and concluded it’s not communicating vs communicating and rejecting what is returned? Erasing the boot sector and partition table can from my experience cause many OS’s to recognize a drive differently then if it has an existing boot sector and partition table.

Don’t post the opposite just to post something, actually back up your statements with some type of logical fact or even a good logical guess.

Hot plug isn’t a default and configured the same accross OSs much less distributions - plug it in, no response, blank drive , no response.

If the device isnt looking for a hot plug drive, it really does not matter how much you have absolute evidential proof - as you see it

Yes I would agree with that, is the OP trying to hot plug the device?

What I can say on the Quad at least is that I tried multiple drives, didn’t get a Format prompt after installing a drive and power cycling. After erasing (zeroing) the boot sector and partition table I then was receiving the prompt to Format immediately after power up. I tested this with multiple drives. I did however get a Format prompt for the very first HDD that I started with. So everything worked as expected up until I tried to switch to another drive, after that I was only able to get those other drives working by zeroing the boot sector and partition table. Why, not sure.

Maybe there is a difference between hot plugging and hot swapping.

And if you boot the tablo without the USB HDD plugged in, enter the settings menu, and plug the USB cable in, USB detection of might occur and the format prompt happen faster.

Of course the whole question of USB device detection, connect, and enumeration protocol is explained on the Wiki page

Two men enter one man leaves - thunderdome

To be clear, it works as engineers designed. When you started playing “tried to switch to another drive” it didn’t go as you wanted. You didn’t query the server about hardrives (since you’re beyond standard user stuff here).

Not knowing or fulling understanding the technicalities involved…

So the logical answer for everyone is to completely wipe a drive. While the post from this user just needed to get the sequence just right.

Just formatted a “used” drive, partition table and filesystem intact - hassle free! Initially it said No Storage Unplugged drive, counted to 10, plugged it in and - Format Drive? came right up! Didn’t care that it had already had a filesystem on it, of course it wanted to re-format it.