Night of experimenting with Fire TV

So just in case anyone was thinking of doing this, I can save you some time.


Last night I side-loaded Firefox onto my Amazon Fire TV.  From there I connected to my.tablotv.com.  Everything connected successfully, but was terribly slow (Go figure…  Not being used as intended).  All the menus populated, and all the artwork eventually popped up, but without a mouse or touch capability you aren’t able to select any of the shows.  So in short, everything looks pretty, but no joy as far as watching…  Back to waiting for a dedicated app, or Plex channel release.

I didn’t expect it to work, but hey, no harm in trying…  :)

Delay in population almost sounds like a network issue, is your Fire TV connected via wired or wireless network?   Aside from slowness issue which sounds like a no go, an air mouse is an option until they release a dedicated app which functions with a remote.    As it sounds like you are comfortable sideloading apps with your Fire TV, how about loading Chrome browser and seeing if you can access my.tablotv.com ?     Try using USB mouse

I would agree with you on the populating issue as far as wifi, but everything else in the house that runs tablo on wifi is quite a bit quicker.  We are talking minutes to load the artwork, not just like twice as long.  That said, I have an ethernet cord that will reach, so maybe I will play with it a little more.  


I was hoping that the of Fire controller joypads would act as a mouse, but unfortunately, that wasn’t the case.  Connecting a mouse didn’t occur to me last night.  I’ll have to try that.  Do you know how Fire TV handles a mouse?  Does a cursor appear on the screen?  I also sideloaded the history channel app, and the login button is unreachable without a mouse, so it would be great if that worked.

The Chrome browser is something I was going to try, but ran out of time.  I assume it will work fine on the Fire TV, but the only browser I saw confirmed working on the XDA thread I peeked in on was Firefox, so I went with that one.  I’ll dig deeper in the next few days and update the thread with my findings.

@jbanks25 - Still interested in testing out the Plex Channel for FireTV ?


Ill have to clear it with Grant because we would need to get the beta firware containing the CGI API loaded onto your Tablo, but other then that you could test it out and give us some feedback… knowing of course that things are still in Dev mode :slight_smile:

@PiX64 Ready when you are…  I’ve got unsupported devices for days and all the Plex infrastructure I could ever want :slight_smile:


I’m always up for Dev Tetsing/Early adopter punishment. :wink:

@jbanks25  -  My fire isn’t currently plugged in but I think I remember using USB mouse and keyboard.    According to the list at XDA, http://forum.xda-developers.com/showthread.php?t=2756608  Chrome browser should work and may be worth trying to access my.tablotv.com

@7up @PiX64  So in short, Chrome and the webapp work as long as you have a mouse hooked up.  The caveat here is that there appears to be no way to fast forward or rewind.  Clicking on the progress bar with the mouse does nothing.  Firefox does not work mouse or otherwise.  The lag I was experiencing appears to be totally due to Firefox.  So side loaded Chrome with my.tablotv.com + a mouse is very similar to my Chromebook watching experience (caveat from above aside).  Fun stuff.  Side note, I was really happy with the whole mouse thing because I was able to log into the History Channel app I wanted.


Other thoughts…  If I had the tablo apk to side load I see no reason at all why it wouldn’t work.  The mouse simulates touch, and it runs in Android 4.2+…  I’d do it tonight downloading the APK with my chrome browser extension, but unfortunately, I can’t see the tablo app in the play store because I don’t have a single device that is compatible with it (One tablet is too old, the other has too low resolution)…  ^&%$*$  :)

download the apk


http://apps.evozi.com/apk-downloader/

Waiting to hear back from Tablo on getting g u the beta firmware so u can run Plex channel

@Pix64 Awesome!


I had beer league hockey championship late into the evening last night, so I’ll make another run at the Fire TV with the side loaded tablo tonight…  Just because :slight_smile:  

No Joy


Side loaded Tablo app cannot seem to locate my Tablo…  Any tricks anyone can think of?  Tablo and Fire TV were both wired, and status ring just kept turning, and never made the connection.

In the end this all doesn’t matter with Plex and dedicated App, but I really thought it would work.

I have no time to play until this weekend but I’ll try and sideload it and see if I get same result

is there an eta for a dedicated fire tv app for tablo?

I had beer league hockey championship late into the evening last night...

Did you win??? 


@Tablotv Sadly after dominating the regular season we fell apart and finished 3rd.  No worries though, I play pretty much year around.  Skate on Wed. and tend net on Sundays.


Darn! Hope you get a chance for redemption next year! 



Finally found some time to experiment with TabloTV and FireTV.


Sideloaded TabloTV app:  Installed fine however app doesn’t appear to be able to access network and can’t see Tablo :frowning:    Same results as jbanks25 above.

Chrome Broswer:   Can access my.tablotv.com fine.  Live TV works but didn’t go full screen.   App seems a little buggy, which I’m not sure is a function of running on FireTV or if its just the Android app.    No crashes but some of the menus were a little flakey.

Thats all for now.    Looking forward to a native Amazon FireTV app   :wink:
delete duplicate post

Chrome browser on phones has same issues with “full screen”… for right now “official” support is that you merely run it inside of a browser window (not full screen).


deleted double post