New User / Can't get guide data to download

So I just cut my cords from Dish Network. I am trying to setup this Tablo 2 to record network shows I like. The setup went smotth. Hard driver installed, connected to router via CAT5, downloaded and installed latest firmware, linked my Tablo to my account (already paid for first months subscription). 24 hours later, I have ABSOLUTELY NO GUIDE data. I have added the channels I want to the guide, hit the button to refresh it but still no joy. Any ideas? I use a 4G LTE connection for the internet (via a cell phone) and am connecting the Tablo 2 via hardwire LAN connection to an Almond Router I have setup as a network extender.

Thanks for any help.

@cryptologic - Tx for your purchase. Try using a nearby zip/postal code. If you’re in a new development or have a unique zip, there may not be guide data associated to it yet.

Please also touch base with support to let them know the zip you were trying to use so we can get that fixed up:

I try to change the zip code in the settings. No matter what zip code I use I get a message sayi,g the zip code can’t be verified.

Contact support so they can have a look. But don’t keep emailing them once you create the ticket. It will put you at the back of the queue.

Use until the guide issue gets straightened out. Manually schedule recordings if possible.

Then again if there is no guide at all, you’ll most likely have to wait for support.

They suggested I use another zip code. I live in between Birmingham and Huntsville Alabama. I put in a Birmingham zip code. Still no guide. They asked for my MAC address so they can continue to troubleshoot. About to say the heck with this and just get a Channel Master.