New unit can’t get any live tv!

Just activated a new unit, the apps seem to work, but no pictures on thumbnails and only get crazy circles when trying to watch live tv. Called support, they did the plug unplug game, but nothing changes. Anybody have some hints?

End device being used? (e.g. phone, which one, browser, etc.)

iPad most recent IOS. Also tried on Roku same result

Is the iPad on the same LAN as the Tablo? You must do this (access Tablo on same LAN) first in order for Tablo Connect to work remotely.

Tablo is plugged into Ethernet and units are on the home network, not trying to do Tablo Connect

Could it just still be downloading all the initial guide data, etc?

Very true, guide data, database conversion (in firmware upgrade cases)… these things can take a bit, including the whole “sync” thing.

Could be, is it not useable during that time?

also, and just making sure, you did do the channels scan and setup the channels right?

Yes we did

Switched to WiFi and seems to work, maybe a bad cable, but thank you for your advice, it’s appreciated.