NEW - Tablo Roku Channel Update (2.6.3)


#1

Happy Wednesday Tablo fans -

It’s a little later than expected, but the folks at Roku have approved and pushed our latest update to the Tablo Roku Channel.

Your Roku will auto-update within the coming day or so, but you can force an update by going to your Roku’s home screen then navigating to SETTINGS > SYSTEM > SYSTEM UPDATE.

Here’s what you can expect:



Tablo Roku Channel 2.6.3

  • Adds text search functionality to Guide
  • Adds ‘help’ screen when no Tablo is found on the network but has successfully connected previously
  • Adds support for Surround Sound in Settings screen
  • Bug fixes and many overall performance improvements


This update also includes new warning/guidance messages related to Surround Sound and network connectivity issues.


We hope you enjoy this update!

If you have any questions or concerns, don’t hesitate to drop us a line or comment below.


#2

Even after the update and turning surround sound off I still can’t play my recorded shows. I get an error that says “your Roku is not connected to a device that supports surround sound.” I have an older plasma TV that is Stereo only.


#3

Were those shows recorded when Surround Sound was turned on? Or is it all recordings?

Also you may wish you review this KB article:


#4

I have three Roku’s, One is a Premier Ultra attached to TV through a surround sound system and Two that are Roku 3’s attached directly to a TV no surround sound. If I enable 5.1 on the Ultra can I not enable it on the Roku 3’s? Thanks


#5

No. Surround Sound is a GLOBAL setting.


#6

If your TV doesn’t support surround sound, turn off surround sound on the tablo, and set the roku audio to either auto or stereo. Does that work?


#7

I gave surround sound a try, but noticed some, but not all channels when played on on the Chrome web browser on my Widows 10 machines had no sound. Turning off surround sound fixed my problem. The Win 10 Tablo app worked the same way.

Anyone else see this


#8

Per one of Tablo’s blog posts, Chrome doesn’t supported surround sound on Windows.

For me, the Edge browser works in Windows 10, though for others it didn’t.


#9

I have the same problem. I checked the audio setting on the roku and the surround sound was on. I am not sure how or when it was turned on. The roku is connected via HDMI to a older stereo tv.
So I now cannot play the episode at all on roku. (No video or audio on Aug 6 2018 episode of Elementary on CBS). I get the error "your Roku is not connected to a device that supports surround sound”.

I went to my desktop computer and using the chrome browser on win 10 tablotv app, I was able to play the video with no sound. I turned on closed captions and it was like watching a foreign language captioned movie however.

why can’t I do the same for the roku (watch video with closed captions)??


#10

FYI you don’t need a Roku to watch the Roku channel (in the USA):


#11

Roku 3 cannot downmix 5.1 to stereo, so it must pass-thru the 5.1 bitstream to the TV. If the TV can accept and decode 5.1 on the HDMI input, then it should work fine. All of my TVs can accept 5.1 (and decode and output stereo.)
Usually if it’s an HDTV then it can decode 5.1 because ATSC (HD) broadcast is Dolby Digital audio. Usually that means it can also take DD on the HDMI input.

“Enabling” it on Roku means you’re enabling it of the Tablo for future recordings for all devices. So you can’t enable it on just the ultra and leave it off on the Roku 3. If you enable it for one, you’re enabling it for all.

I would suggest you turn on surround sound then go play live TV on all of your Roku devices to see if you get audio.


#12

Thank you for the suggestion. My Roku 3 TVs do not work with surround sound on.