NEW - Tablo Firmware Release 2.2.20

Happy Wednesday Tablo fans!

A new maintenance firmware update is on the way for your Tablo!

(UNLESS you have a Tablo DUAL LITE, in which case yours is coming in the next few weeks, so stay tuned!)

Like previous releases, this firmware will be offered in a staged rollout. A small portion of users will have access to this firmware immediately. We will increase access slowly as we judge feedback and distribute the firmware to increasingly larger batches of units over the coming week or so.

Here’s what you can expect…

Release Notes for Tablo Firmware 2.2.20
• Corrects issue with ‘orphaned’ recordings
• Additional speed optimizations for channel tuning
• Fixed rare situation where Tablo Connect could stop working, if ports were manually configured
• Other reliability and performance enhancements

NOTE: Post-upgrade database processes (if needed) may take several minutes to complete. During this time the LED will be blinking. Do not power down the Tablo until the LED is solid again.

The other change that users may notice with 2.2.20 is that Live TV and Recording Quality settings have been decoupled.

This means you can set the video quality and bit rate of Live streams from your Tablo differently than settings for Recordings.

You can read more about this change and what it means for Tablo users on the Tablo blog:

For tips and tricks on successful firmware updates head over to the Knowledge Base.

If you have any feedback or questions about this release, please post them below.

If you need support assistance, place a ticket and we’ll be in touch.


I sure wish you guys would fix the issue with the live TV going back to the guide when a recording ends. That is very annoying. Otherwise love it!

1 Like

Agreed. It’s very confusing, especially when a program runs beyond its scheduled time slot.

I think if you click on the channel number instead of the show when you decide to watch something live, it won’t end when the show does. This is the work around I use and that problem doesn’t bother me near as much as it used to. Clicking on the channel will keep it playing forever, where clicking on the show will stop playing as soon as the time slot is over. Pausing the video while watching will cause it to just to the guide when the time is over even if you are still watching the show.

On the Roku, Live TV won’t end at the end of a channel recording, if you start watching Live TV on that channel before the recording begins.

Sad that there is no Chromecast updates, can’t recommend this with the way it works today, everyone I know has Chromecasts, do not know a single person with Roku. Small antenna signal degredation cause big pauses on CC. Funny though when routed through tablo plex channel, it does not do this but that channel is flaky.

And the Android app, can only cast once before you need to reset the app before casting again.

Big shame really, huge missed opportunity. Would be awesome to say to Google home (like I do on Netflix) “watch CBC live on TV”.

And I do not buy the Tablo forum post about ‘Chromecast is a screen mirroring thing’ because it is not. Looking to see how plex DVR is coming along since I never get CC issues wtih plex.


You’re right in your thinking.
While Chromecast can perform screen mirroring, it’s not the same as casting.

Screen mirroring sends the screen content updates of the sending device (computer, tablet, …) to the Chromecast.
Casting sends the streaming source info (Netflix movie, YouTube video, …) to the Chromecast, which receives the stream from the streaming source (Netflix, YouTube, …), not the device that originated the casting request (computer, tablet, …).

I think I got that right. :slight_smile:

1 Like

Mine arrived in the “mail” today! So far I’m very, very happy. All of my problems seem to be solved (except for one), and I found the work around for that. On all of my Roku devices, everything (including very high density recordings) work perfectly. All of my TV’s are now Roku TV’s with two exceptions. Two of my older flat screen TV’s have Roku devices installed. One small TV will only process 720p and all playback works fine. The other will process either 1080p or 720p and automatically connects at 1080p. Oddly, low density recordings work fine, but high density recordings buffer like mad! I tried everything until I thought to look at the connection density as a last resort. I overrode the automatic setting and dialed it back to 720p. Now everything works fine.

I never had this problem on the 2.2.16 firmware, only on 2.2.18 and the new 2.2.20. My workaround has solved the problem, so if you are using a Roku device rather than a Roku or Smart TV, check the video settings on the Roku Device and manually set it 720p if you are buffering only on that device.

Not true. I clicked on the channel number and as soon as the recording stops, it stop playing. It did not kick me back to guide, just stop. I need to go back to guide and click the channel number again. Very annoying.

Yup. It’s the latter that needs work. I can actually more reliably mirror from a laptop which makes no sense at all.

I am looking forward to live TV at a different resolution than recordings! The next best feature would be to set the recording quality for each show. I want 1080 for my sports recordings, but 720 is fine for regular TV shows. As it stands, I can’t record two different qualities for different programs at the same time, and that is a shame. During NFL season, I up the quality on the weekend to 1080, but all my other stuff also records at 1080 during the weekend, eating up valuable space. Same for the Olympics. I wanted that stuff at 1080, but my regular shows at 720. Sure would be nice to have this capability.

Please consider this for the future!


I would love this “res-per-show” again. The old VCRs had this :wink:. i don’t need to see the fine details of Lester Holt’s left ear during the nightly news, but a fantastic catch or Nova’s latest show really is nice in HD !

I would love it if the 2.2.20 release fixes the bugs introduced in 2.2.18.

Release 2.2.18 didn’t contain any changes that were of interest to me. So I stayed on 2.2.16 until 2.2.20 was announced on May 16th. I have multiple tablo units and phantom recordings happened immediately after the upgrade across all units and at a rate of around 30%. It’s impossible to believe that testing wouldn’t or shouldn’t have seen that bug.

And what’s up when the WEB app performs a channel rescan. The progress bar/screen appears to stop displaying channels somewhere around UHF channel 22. My area has around 31 channels. The Low and Hi VHF work as before. But channels 22 and above aren’t displayed until the very end. And then puff they all appear at once.

1 Like

when are they going to giive us the update to firmware??? this is ridiculous i mean what is taking so long???

Usually a week to 10 days.

Hi zippy. Are you referring to the Win10 app? I’ve also had issues using this. I see the same channel scan issue here with 31 channels. I believe this began with the app update a week ago. Also, since before the recent app update and not fixed, and only in full screen mode - the REW20 and FF30 buttons disappear when hovering over them with the mouse pointer. Just a blank space there until I move the pointer away but functionality is ok - it’s just annoying. And now, after deleting a recorded program, it stays in the list of recorded programs until I exit to another screen, Live or something, and then return. Sometimes they won’t go away until I completely exit out of the app and then return. This behavior just started with the 2.2.20 update. And recorded programs take up to 30 seconds to begin playing after clicking ‘play’. This never happened before on any platform I use. Also noticed that synchronization between the app and the Roku are not on the same page. Watched a recorded golf tourny today to about halfway through on the app and then later picked it up on the Roku and it started at the beginning. I had to FF and figure out where I was. This just started with the firmware update as well. Seems like the firmware might have broken the app - or at least messed it up a bit.

I’m referring to the WEB app accessed via a browser.

Of course we could talk about the other bugs. Some of which have been outstanding for over 2 years but why.

Today I got the notice to update one of my tablo units to 2.2.20. So I did.

It kind of fixed the phantom recording problem. The ghosted episodes and show tiles reappeared.

But so did two shows that had no recordings. I installed 2.2.18 on May 16th. These were shows that were recorded before the upgrade to 2.2.18 and the only episodes were watched and deleted while on 2.2.18.

While these empty show tiles don’t appear in the WEB browser and the Fire Stick app. They do appear in the Roku and Fire Stick preview app. These apps may also allow me perform a delete. But I’ll hold off for a while.

I also don’t remember these empty shows being there after the installation reboot. They may have appeared after I watched one of the ghosted episodes and deleted it.

Firefox no longer connects to the Tablo after this update. I preferred to use Firefox because the captions worked so well. In Chrome, long captions would appear out of order (the second line appears on top of the first line). Although, so far, I must say the captions are working correctly in Chrome.

Mine too. neither browsers connect