New Tablo Delivered today and not working

I was so excited to get home this evening to setup my new tablo. I got my HDD ready, tested my ethernet connection with my laptop then I plugged it all in… Then came the epic disappointment as all this wonderful little box will do is flash a blue LED.

No light on the ethernet port on the back, not light on the switch either.

Tried wireless setup, cannot find the wireless name tablo_XXXX.

I tried the reset button… does absolutely nothing, light continues to blink with no change. Held it for longer… nothing changed.

Any ideas?

If the Ethernet cable is live (you tested with a laptop) and you plug it into the Tablo and the lights on the back do not turn on then the Tablo is likely DOA.

Return it for a new one.

Try holding the reset button until the LED rate of flashing increases, faster and faster, and then goes solid blue (Takes something like 10 seconds to do), and release the button after the LED is solid blue.
That is a full factory reset.
If that doesn’t fix the issue, you must have a hardware problem.

Tried it here again at work, same thing.

I held the reset button about 20 seconds, no change in the blinking light, never speeds up, never slows down, never stops.

There is also not lights on the NIC either.

If I listen with my ear on the device I can here a ticking noise with each flash of the LED.

Sounds like you have a dud…
Return it for another one. It’s a great product and worth trying again.

Very bad sign when a live Ethernet cable.