NEW Firmware Release - 2.2.14


Well mate, I’m on the 2.2.14 and don’t see any worse signal reception than before. I have some channels that were dodgy before (because I need a better antenna) and still are dodgy. One thing the wife noticed was that her shows did sometimes split into two recordings and she says hasn’t seen that for a while. I don’t know if that is just good luck with the reception or if that is one of the improvements.

Good luck, mate.


I was used to doing a weekly cold reboot of my frozen 4 channel Tablo located in the garage. Now the thing is rock solid ever since this firmware upgrade about a month ago. Thanks to the developers for whatever they did to their software. It might have been a memory leak, HD compatibility issue, or …? I’m just glad it’s working great now.


This thread contains more reports of problems as apposed to successes. Such is the nature of this forum.

After watching these posts for awhile, I decided to take the plunge and update my Table-Quad from 2.12 to the latest release 2.14.
The whole process took less than 4 minutes. That’s with a hard drive containing 1.75 GB of recordings.

I’m happy to report that my upgrade went very smoothly and so far I have not had any problems.
Hats off to the Tablo team for a smooth upgrade and a great product.


I realize you got it working but have you considered LTE interference?

Somewhere I commented that I have to re-align my antennas a couple times a year as seasons change and that for me at least, I was fairly certain it was just a coincidence that it aligned with this firmware this round.

Well, I finally got around to my seasonal adjustment last weekend and unfortunately it did not correct all of my issues. I still had ONE channel that was unwatchable…

I found a thread here about possible LTE interference and decided to try one of the recommended filters.

Problem solved!

Not sure if it helped enough to keep me from having to realign a few items a year but I am really optimistic about it.

I know the larger antenna fixed your issue but maybe something to consider, especially if it comes back later.

As a bonus, not only did the filter fix my one troubled station but I picked up two new ones!


I upgraded my Tablo four-tuner unit to a new 8GB USB 3.0 drive.

It seems to be working OK except for a few small problems. I have noticed some recordings start with “recording failed due to weak signal” but the recording does continue with a second data file just a few seconds later. I do not ever remember seeing that problem occur when using my older Seagate 5TB USB 3.0 drive.

I’m wondering if I have a weak tuner or if the USB drive is slow to start after a quiet recording period and the Tablo error message might be incorrect to describe the true problem.

I had high hopes for this drive since it is supposed to have a hard drive rated for 24/7 operation in server configurations, which should make it ideal for OTA recordings.


Had a WD 1.5g drive before, use to get a lot of broken recordings too, switched to a 5 gig Seagate drive few months ago, never happened since.


I do have an option to turn off the sleep mode on the drive, but would rather not do so in order to extend its service life.

Perhaps if it were possible the Tablo could “ping” the USB drive a minute before recording begins in order to wake it up if it is in idle spin-down mode at the time.


Leaving the sleep mode on when using WD drives has been a known problem for a while. Most people have their issues resolved when they connect the WD drive to their computer and turn it off.

At least give it a try for a week and see if your problem goes away.


Thanks for the advice, theuser86.

Actually I think I’ll run it the way it is for now and see how many problem incidents occur. It would help me if anyone knows of any references to the pluses and minuses of turning off the sleep mode. In particular how many years of life I would lose on the hard drive if it would spin continuously. Maybe some MTBF values for the WD Red drives.

If a slow hard drive startup does indeed cause problems then the Tablo error message should state so correctly and not give a misleading message, like “weak signal” if the signal was not really weak.

I really believe Tablo programmers can address this issue and write code to detect the hard drive status prior to writing a new recording and make certain the drive has time to spin up first.

BTW, a long time ago I accepted I could survive a total loss of recordings and start over with a new drive. This eliminates a lot of stress. That said, I still would like to max out the life of any new drive I install.


I may have found an answer to my question.

I still will monitor performance with default sleep settings but will probably eventually disable it.


The purple drives are probably better suited. They are designed for constant video capture.


The Red drives are for constant on. While the Purples are for constant access, read/write.

I can’t imagine what kind of puddle of molten silicon you would find inside a tablo case if it recorded 24 hours a day for 365 straight days.

And what is the MTBF of a tablo unit?


I had not considered 4G LTE interference. I guess anything is possible, and I believe there just might be a cell tower ~1 mile from my house. Strangely, almost all of my pixelation has diminished when I changed the recording quality down to the recommended “HD 720 - 5Mps” quality. I have a 65" Sony 4K TV so the decrease in quality is actually noticeable.

I will consider this, though. Maybe I could bump back up to “HD 1080 - 8Mps” if I were to install one of these filters?


Possibly my new Netgear Orbi AC2200 router/satellite? Or is this a side effect of the latest update?

I have noticed something happening a little more often than it used to. I can be watching live TV, where I open a channel at the channel number/description box on the left edge of the live guide. After a while, sometimes, I will get an error that says it lost connection to my Tablo. I can resume by exiting back out of Live TV and then going back in and going back to the same channel.

I used to only see this error if my Tablo was reset, or power cycled.

Anyone else in this forum have the Netgear Orbi router and satellites? If so, do you see this problem as well?


I bought would recommend a WD Purple drive simply because it was the quietest (Tablo in my bedroom), works great otherwise.


I updated my Tablo to the latest firmware two Sundays ago. Happy to report that everything is working fine. I did notice an improvement: my Tablo used to hang (requiring an A/C cycle) if I deleted too many shows in a short amount of time. That problem seems to have gone away with the new firmware.


My apologies for the overdue reply. Due to an extended absence from home and TV in general, I’ve just started using Tablo again and I still have the same issue…casting natively from Tablo to Chromecast Ultra fails but casting from Google Home and then running Tablo works…albeit jumpy at times. And like you reported, I hadn’t encountered this problem in early April 2017 before I left for a month long vacation in Myrtle Beach.

Here’s an update with my hardware config since I posted last:

I have a Netgear 7550 DSL modem (provided by my phone company) bridged to a LinkSys EA8500 router. I have a 30’ Cat5 cable between the Linksys EA8500 router and a Netgear 5 port Gigabit Ethernet Plus Switch. Hanging off the Netgear switch with 3’ Cat5 cables are only the Tablo and the ChromeCast Ultra. I have tried my Android devices with Tablo on the 2.4Ghz and 5Ghz Linksys EA8500 radios and the behavior is the same. In summary, Tablo and ChromeCast Ultra are only 6’ apart with a Netgear Gigabit Switch in the middle and casting with Tablo fails and casting with Google Home works.

Hopefully the issue has been resolved at your end by now and I’m anxious to hear how!



This is the best update I’ve seen you put out thus far. When I bought my Tablo 2 years ago it was nearly unusable with how slow and clunky the interface was. I actually put it back in the box, put it in the closet, and didn’t use it again until just a few weeks ago. With 2.2.14 it is very responsive and much faster than before. I now use it for all of my OTA TV viewing. Great job!


Hi Tim,

Sorry I did not reply quickly.
After nearly 6 months of diagnostics I have not been able to resolve my problem.
(No casting after firmware update)

I bought new routers and chromecasts and NOTHING. The problem is still the same.

Today, I gave it my last go-round:
I disconnected my complete network.
New Linksys router hooked directly to the internet.
Used it’s WIFI to run the chromecast and the tablet.
SAME PROBLEM. Still can’t cast to the TV. It might cast once but that’s it.
Further attempts to cast to TV fail by simply stopping. Not a crash just a halt.

Like you, all this happened right after Tablo’s automatic Firmware update.
It appears that the Tablo got trashed.
It works fine if you just want to use it on a tablet.
However, after a while the small screen will drive you nuts.

You said you were vacationing at Myrtle beach.
Too bad I didn’t know. I live here.
We could have met for a beer and lamented about our Tablo problems.



Returned home and casting with Google Home to the same enironment described in my last post results in pixelation and occaisional loss of audio. I had to reboot the entire environment to get audio back and sometimes could not resume or start fresh with a partially viewed recording.

In desperation, two days ago I decided to try a Roku 4 Ultra (wanted cat5 connection and store was out of Roku Premier Plus). I’m pleased to report all issues have been resolved. Exceptional quality video, no pixelation even on1080i the revordings that had pixelation previuosly, no hangs but instant response, fast forwarding even works! Just like one would want and expect! Works fine with the included Roku remote only once the Tablo is setup in the Roku environment.

FYI Since I only wanted Roku for the Tablo environment I wasn’t anxious to provide a credit card to Roku. During the Roku account create process, when asked for a credit card I selected Paypal. When I dot to the paypal portal logon, I simlly killed my browser. I then logged back into the Roku account create process using the id and password and was able to bypass the credit card environment.

I hope this helps.