New drive but old recordings showing up

I’ve had to replace the USB hard drive.
New drive is working but the old recordings are still showing up. Or, at least, they LOOK like they’re still there.
Is there a way to ‘flash’ the Tablo software so that it realizes those old recordings aren’t actually there?
I’ve tried deleting and re-downloading the app ((Apple TV)
Unplugging and replugging in the hard drive.
Firmware is 2.2.42.
Thanks

Tablo performs overnight housekeeping tasks that are supposed to clean those up on legacy units, assuming 4th Gen is the same.

You could also try deleting the phantom entries manually.

From the perspective of the legacy units. The DB with the data is stored internally, all the guide data, recording data and scheduling. The recordings are stored on the drive, this why you’re seeing this. As noted, at least legacy, maybe 4th gen, leave unit alone overnight and it should clean it’s self up. I do believe others have noted success and I may have as sell.

Depending how elaborate your recording schedule, not recommended, you could reset your unit. If this is your only concern and it fixed it’s self, reset is unnecessary.

This is a legacy unit (dual lite).
It’s been an overnight as of now but old programs are still showing up.
I guess I’ll give it another overnight.