Need help with commercial skip

I have a Tablo Dual LITE setup with cloud DVR. I tried the commercial skip feature which didn’t work. Then I found out, it won’t work with cloud DVR recordings. So I connected a USB drive and cancelled the cloud DVR. The USB drive works great, and I have no trouble recording anything, but I can’t seem to get the commercial skip feature to work.I have commercial skip ON in the Tablo channel on the Roku. Equipment specifics are below. Any help will be very much appreciated. I want to make sure it works before I add the premium feature.

Roku Ultra model 4670X
Channel ver 2.13.1
Software 9.2.0 Build 4807

Tablo ver 2.2.26

Try to turn off skip then put back on. Worked for me with AppleTV

Toggled on in the overall Tablo settings or toggled on in the playback screen? It needs to be both for it to work.

Thanks for your response. Although I’ve done this multiple times through the Tablo app on the Roku Ultra, I tried it on another TV that has a Roku Streaming stick. This time, when I opened the Tablo app, it immediately informed me that commercial skip was available and gave me the option of turning it on without going into settings. I scheduled a couple of programs to record. To my surprise, one was commercial skip ready and worked great. The other one failed to upload, but at least I knew it had tried. Since then, I’ve done the on/off thing on both Roku devices and scheduled several recordings, but commercial skip didn’t work for any of them.

Yes, I have it on in both locations. Thanks!

RESOLVED - Not sure what changed, but commercial skip seems to be working now. Apparently it takes closer to 2 hours to process rather than 1 hour.