My Tablo app not working on Roku

Until recently, I was able to see my 4-tuner, wi-fi Tablo using my Roku Streaming Stick. Now I can still see the app on Roku, but when I try to start up Tablo. I’m taken to a page that describes how great Tablo is and how to buy one. It also has a button to search for my Tablo. I tried every troubleshooting tip I can find. Finally Roku Support told me the problem is that the Tablo app has not been updated to support the new Roku firmware. True? When will the new release of the Tablo app be available?

That is not correct.

The only way you should see this is if your Roku and Tablo are not communicating correctly across the network.

You say you’ve tried all of the troubleshooting tips… Have you tried all of these in a series (aside from running a new channel scan)?

If so, and you’re still having trouble, please contact our support gurus as there must be something fishy going on with your network.

Thanks. #3 worked (then afterward #s 1 & 2. The support person at Roku did not even know what Tablo was.

Excellent! Glad to hear you’re all sorted out.

Now he/she knows and knowing is half the battle!