Low Volume Fix?

Just bought a Tablo Dual yesterday and love everything about it except it outputs exceedingly low volume to all my apps and devices – phone, tablet, Roku, Chromecast and all web browsers on all my PCs.

I then ran an experiment: recording the same local newscast both to Tablo and an older capture card on my PC. (Neither has an adjustment for changing the input volume, so the audio of each was recorded at its default “line level.”) I saved both to PC, edited the timeframes down to exactly the same start and end points and measured the audio amplitude of both.

The results? The Tablo outputs audio at a level 12 dB quieter than my old Hauppage WinTV. This is unacceptable. I have to max out the volume on my TV just to hear my Tablo recordings, and even then I miss things. Is there a firmware fix for this? Because I already love the functionality of this thing, but I can’t see myself keeping it otherwise.

1 Like

That’s strange. I just ran some tests with my Tablo on my PC (Chrome), phone (Android), and tv (using the Roku and the Samsung app).

The PC has a seperate volume slider, so make sure that isn’t set to something low. I played back some Youtube and Netflix, and the sound seemed the same level as my Tablo.

On my Android phone with no headphones, I usually do have to almost max out the volume, but I have to do that with all my streaming apps.

And on the TV (this particular tv has no sound bar or external speakers), the sound was the same level as other apps. I was on level 8 and could hear the Tablo clearly. Just make sure that no “night listening mode” is active and that you are using Auto for audio on your devices.

Tablo support has said in the past they do nothing with the volume received, and they also have said there is almost nothing they can do besides double it (which would be too loud most likely).

Why not try working on one device at a time.

As an example.

There was a time my 4200 Roku had low volume, my 4210 and ultra were fine. So possible a Roku problem could be model specific.

My 4200 audio was always set to Medium volume and audio mode auto(DD+, DTS) I never used 5.1.

Eventually over a couple of Roku OS updates the volume was as normal as the other Roku’s.

Thanks, but yes, the videos were indeed recorded “one device at a time,” which is to say, independently on separate devices tuned to the same OTA newscast. No adjustment was made to the incoming audio in either case – both were recorded flat to disc – and then loaded into Adobe Audition to measure the amplitude (naturally the Tablo file had to be migrated to my hard drive first, but TabloRipper makes no changes to the specs in so doing).

The Tablo audio output is simply too quiet.

it’s not just you. if you search the board here, you’ll see that it’s a topic that comes up pretty often. if your devices can do 5.1 audio, that usually fixes it. if you do standard audio, you’ll forever be stuck with low volume. I keep hoping they’ll change the transcoding settings in the background to up the volume, or give some setting in the user interface, but so far, no go.

all things considered, this isn’t a problem for me, as long as I remember to turn the volume down before I turn off the tv or switch to another app. (If I forget, I get a few seconds of youtube or hbo blasting)

probably not, buy unless you know the switches passed to ffmpeg it’s not completely “known”.

Your Hauppage WinTV likely captures raw mpeg data while your tablo transcode it to HLS (streaming format), then you streamed it through ffmpeg to create an mp4 (aka compressed video)

I do believe you have volume issues, other brought it up in the past. Just not sure this is an equal 1 to 1 test. Although it’s not with out some results.

Have you turned on the surround sound option in the Tablo?

This will only work for future recordings.

The sound level of all of my OTT services, including tablo, are very close. And that is across 3 different models of Roku and 2 different models of Fire TV Stick. But not as loud as direct antenna TV and I don’t use 5.1.

I learned to live with low sound on one of my Roku’s and it was my primary unit. Eventually after a number of Tablo and Roku OS updates things got better.

Maybe tablo support will get into your tablo unit and turn your sound level up. Or???

…unless you know the switches passed to ffmpeg it’s not completely “known”.

Yeah, I was going by what the TabloRipper dev said in an earlier post – but as you say, right, it’s not completely known.

Have you turned on the surround sound option in the Tablo?

I did. In my case it had the effect of disabling/muting all audio.

During playback on the Roku you can hit the * key to bring up an Options menu with some volume options. Not sure if it will make any difference, but easy to try.

Thanks. Yeah, I read a great many posts on the topic before deciding to add mine, in the hopes that 1) maybe someone will point out something I missed, and 2) the combined weight of all these customers still experiencing this exact same problem after such a long time (and a very fundamental issue – inadequate audio! – at that) will finally spur the developers of this otherwise fine consumer product to finally do something about this!

Just understand that this is not an issue shared by most of the user base, and there is nothing that the Tablo folks can really do except for doubling the volume, which would like cause more problems.

Your best bet is to explain your particular set up in detail (TV make and model, any external sound system, streaming device make and model, stream device sound settings, etc). Hopefully someone with a very similar configuration can help.

Well, you know many people are satisfied.

Should they change and make those unhappy and you happy?

When the volume was low on my primary view unit there were always other options. But I put on my big boy pants and focused on more important things in life.

The 5.1 AC3 audio should work on devices connected to your HDTV. Almost all HDTVs can decide 5.1 AC3 audio over HDMI.

You should just need to setup the playback device to passthrough the audio to the HDTV over HDMI.

But I put on my big boy pants and focused on more important things in life.

Doesn’t “wearing our big boy pants” mean not stooping to putdowns and incivility?

I’m not recommending they change things that work. The fix could be as simple as offering an audio preamp option in settings allowing users who need it to specify a volume boost between, say, 0 and 12 dB. Pretty simple to implement from a coding standpoint, and the computational hit is negligible. And of course, those who don’t need it would just stick with the default.

The Tablo team has already stated that this is NOT a simple fix. The transcoding is done in hardware, and the hardware does not have the option for small adjustments. Their ONLY option is to double the volume.

3 Likes

Over the last 5 years Nuvyyo has made any number of changes and those also include sound.

Tablo has to support a large number devices and their various models. I’m sure they probably pick a sound level that works the best on all of those devices.

But if you want to code up a prototype I’m sure they might look at it. It should be pretty simple.

And I’m the only one allowed to put on my big boy pants. How you decide what is important and make critical decisions in your life is up to you.

1 Like

Zippy, “snippy” is not a needed response here, in my view. The low-volume issue is widely encountered, and matters to some, doesn’t or is liveable to others. (I just turn up the volume for Tablo, though it would be nice not to have to.) I’ve got no issue with someone saying, as above, that they hope that by adding their voice this will become more important if it ever is feasibly subject to an adjustment. And I’ve no issue with saying unfortunately a Tablo user may have to live with it.

In my experience most people don’t have to note the kind of pants they (let alone others) are wearing.

1 Like

A new user who has issues with the sound level on all of their devices and also thinks that tablo development is going to drop whatever they are doing and code a simple fix may be surprised.

Since all of the user devices are impacted the only thing that may be possible is that tablo support connects and sees if anything is wrong. Or maybe make some local user specific changes. And I’ve haven’t seen them do that in 5 years.

I really doubt that forum users are going to make any immediate fix happen that makes all devices suddenly work. And those 12dB magically appear.

So at some time I would think that a user would have to decide what they are going to do. Nothing is stopping them from opening a help desk ticket.

So when my device had the problem for around 2 years I was able to decide.

1 Like