Loading, please wait on Roku 2 connected via Wifi

Just got my Tablo last week and love it.

Have the Tablo and 1 Roku 2 connected via Ethernet (Netgear R7000 AC 1900 Router) on my main TV and everything works great.

Have a second Roku 2 in a room on the upper floor. Bought a TP-Link RE210 Range extender and tried to connect via Wifi and Ethernet. Recording play back fine but live TV issues a “Loading, please wait” message when you start playing a new channel.

I also have the video setting at 1080i - would changing to 720p help?

Would a powerline adapter work better?

Thanks to any advice out there. Just trying to address this issue before officially cutting the cord.

I have a Roku2 XS that is wired direct to the switch, and I had to change to 720p to rid myself of the buffering problem. Picture quality has been fine. I am running the “recommended” 720p setting, not the 720p Roku/Chromecast setting.

Likely due to poor WiFi.

Which Roku 2? Model 2720 or 4210?

Get a powerline ethernet adapter. Going down to 720p Roku / Chromecast quality will likely fix your issue as well.


Pretty sure mbellaire is referring to the 3100X which is the Roku 2 model that I have. I run it at the 720p Roku/Chromecast setting, and I am not having problems with it.

I was responding to the OP for clarification - there are too many models that people call ‘Roku 2’ - and its entirely Roku’s fault with their dumb naming convention.

Ah! Then yeah, setting the Tablo to record 720p will probably help a lot, but it probably needs to be the Roku/Chromecast setting for WiFi

Thanks for the replies. Actually believe I have the “live streaming jump back issue” where stream stops and goes back 4 sec and replays the stream. This happens both when my Roku 2 4210 are connected directly to my router or via a wifi extender.

This issue is totally different. Repeating of the same segments of video is due to poor OTA signal and how the Roku handles the stream with errors in it.

Do you see pixelation in the video when this happens?

Which Tablo do you have? 2 tuner or 4 tuner? Remember the Tablo splits the signal. I can watch channel 17-5 on the TV but not Tablo because it is a weak station and after the split it is to weak for the Tablo.

I have a 2 Tuner. My picture quality is very good with no pixelation. I just get the “Loading, please wait” message within the first 30 sec and the stream skips backs 4 sec and then everything is fine. Seems like a buffering issue. There is another thread back in Feb where this seemed to happen to bunch of people.

Uncheck “enable fast live TV startup” in settings.

Id suggest taking the time to add ethernet to the second floor at the end of the day that should be much faster then any WiFi option and probably cost less than a powerline adapter, which is only as good as the wiring in your house, a bad connection or device can render a power line adapter almost useless

I have the same router and it was not very impressive speed wise while transfering 92 gigs of data form a NAS to a backup drive last night, The best wireless speed I got was 12Mbps and the lowest was 200kbps average was 1mbps. I had to give up and plug in to a hard wired connection. My ethernet connection never dropped below 25Mbps although it was far below the 100mbps. the 12mbps was with my laptop located only 5’-6’ directly above my router.

My Roku 2 is hard wired to the router, and my Tablo is also hard wired but insists on connecting to the WiFi and I have no problems streaming at the regular ( not roku/chromecast) 720 setting, it was all but unusable over WiFi

It’s better to have your wireless router on the top floor. Wireless signals fall down better than climbing up. Also, there is a lot of congestion on the 2.4Ghz frequency from all types of devices and neighboring wireless networks. There will be a lot of lost or corrupted network packets making your connection worst than expected. You may want to try 5Ghz. Netgear has a wireless network analyzing app for smartphones that will tell you the signal strength in all rooms of your home and shows what is the best channel for your router to be on.

  • 2.4Ghz is slower but more reliable at long distances.
  • 5Ghz is faster but less reliable at long distances.

Also remember that your network will only be as fast as it’s slowest component. You may have a wireless network capable of 300Mbps, but if the device your writing/streaming to can only consume 12Mbps then that’s as fast as you can go. Add all the network congestion to the mix and things can get even slower.

1 Like