Last device not found

This is probably a Roku-only issue, but every time I back out of the Tablo app, to the main Roku menu, then launch the Tablo app again, it tells me the last device I used wasn’t found, and I just have to hit ‘select’ again, and then it works just fine. It is repeatable every time.

It’s happening on both my Rokus. I think it started when I changed form a hard-wired connection to the Tablo, to a wifi connection.

Anyone know how to get it to stop this behaviour?


Instead of “backing out” of the Tablo Roku app, try hitting the Roku Home button.

Nope - already been trying that. It is 100% consistent.

@AndreTheGeek - What firmware version are you using? I assume you’re also using the public Roku channel?

2.2.9, and the public channel.

I have exactly the same issue. Using a Roku3. Each time I switch to another app like Netflix, then back to Tablo, I get the error “last device not found”, then it immediately finds it and I have to select it before the app will load. I’m using the roku over wireless, not ethernet.

Same problem here. I have 5 Rokus and the latest 4-tuner Tablo. Only the Roku TV and one of the boxes allows me to access the app without the error.

The Tablo is hard wired into a LAN router, which goes out to a couple hard wired access points. The one Roku box that works is connected via WIFI from my modem, and not one of the remote access points.

I’ve narrowed it down to an issue with the Belkin routers that I have set up as just access points. I re-scanned one of the Roku boxes and connected it to the same modem WIFI, and viola, it now works just like the one other Roku.

Now I have to dig into the Belkin settings to see what could be causing this. If tech support reads this and knows the solution, please advise! Tnx.

Be sure those extra Belkin routers are running in Bridge mode, not Router mode.

1 Like

The Belkin routers, I assume they are hard wired to your main router?

Then do you have the DHCP server on the Belkin routers turned off? They need to be turned off so your main router is the only DHCP server on the network.

If properly configured, the IP of your routers will be as follows:
Main router:
Belkin router #1:
Belkin router #2:

All 3 routers need to be on the same subnet of - if your main router is for example and your Belkin router is for example, then that setup will not work.

Yes, bridge mode.
Yes, hard wired.

I pre-wired the then new house with cat5e, but not the TV areas. Internet TV? Streaming movies? Hey, who knew back then, right? I recently dumped the last of the old CRT TV’s and are fully modernized…for at least another year.

So to ensure a strong WIFI signal from the closest Cat5e outlet per TV location, I added the Belkin access points to get a solid signal. They’re have seen lots of activity, especially Amazon Prime movies with zero issues, such as connection or buffering.

These Belkin routers have an easy setup bridge mode. Once selected it disables all other functions to simplify setup as an access point (disables DHCP, etc). They otherwise work perfectly. It appears as if the Tablo doesn’t like something about getting pushed through the Belkins, but after a couple seconds the access button appears, and you have to press the connect button. The Roku’s that are working without the extra Tablo “connect” step get their signal from the modem’s WIFI with no intervention needed.