Intermittent/rare stream freeze with Roku

I’ve noticed that I’m getting an occasional, but rare symptom that has started in the last week or two and seems to be increasing in occurrence.


Symptom:
While watching a show, the stream freezes on the Roku buffering link.  Waiting doesn’t seem to clear.  If I fast forward or rewind a little bit, the problem resolves.  I’m not sure yet, but I think it might be an encoding problem as I can reproduce if I rewind and go over the same piece of video (I’ve done this a couple of times, but haven’t tested it enough to be confident).  The symptom has occurred about four times this week.  A couple of times on a single show.  The show, otherwise, did not seem to have any signal problems.

I rebooted the Tablo today just to see if it has any effect.

Environment:
Roku3 - I have two and have only seen it on one, but I mostly watch Tablo on one.
Wired connections 
Everything connected to the internet and should be up to date


At the moment, this isn’t a major concern.  I’m posting to see if others have the problems and if there is any easy way to troubleshoot.  I’ve debated spending more time confirming if the problem is related to a specific area of the recording and then downloading the videos to a computer and analyze them, but again, hasn’t been annoying enough to invest the effort.

@jimrush There aren’t any known issues like this. One thing to check: are both Roku’s on firmware version 6.1? I know you mentioned they should all be up to date, but this upgrade seems to have a particularly slow rollout.

Thank you.  I will double check my Roku version.  


The issue hasn’t happened again since my point, but it has been intermittent and inconsistent.  Given it isn’t a known issue, I’ll just monitor it to see if it happens again and if it does, any pattern that I can detect from it.