If your direction buttons repeat with Harmony remote on new Roku Preview. Look in here

To fix the repeat up and down. In the MyHamony app go to devices and click change device settings. Click device command repeats and follow the prompts. Mine was fixed by changing the setting to 2. Others had to change it to 1.

The Harmony remotes send 3 signals for each button push by default.

This is a great work around for the issue (thank you) but hopefully tablo plans on fixing the actual issue.


Looks like the issue is with the Roku firmware update to v6.2, not specifically a Tablo lazy programmer.


I ran into this when I was testing a FireTV and Flirc dongle on many apps and a few with Roku in the past even before the Roku firmware update. I have read that it is a common problem with universal remotes. They have to accommodate so many devices that they all send multiple signals for a button tap which is why it is adjustable on the better remotes.

You may have even noticed in the MyHarmony app screens that I reference above it states to use that setting specifically if your having problems with the up/down channel and volume keys.

I’m sure Tablo could make it work with Harmony remotes with 3 signals sent but could that possibly make another brand universal remote not work at all on the up/down keys? IMO this is why it is adjustable on the remote itself and not just a “work around”.

At any rate, I hope my post helps.
This is a great work around for the issue (thank you) but hopefully tablo plans on fixing the actual issue.

Roku has had off and on issues with Harmony command repeats all the way back to my Harmony 650/700 remotes and the original Roku XD. This doesn’t have anything at all to do with Tablo/Nuvyyo, and the only way that I’ve ever been able to solve the issue with the Roku is to drop the repeats to 1.

Roku has never seemed interested in fixing the issue on their end, and in their official support forum they have in the past linked people with the issue to the Logitech support page that details dropping the command repeat rate.

I’m using 3 Harmony 880 remotes.  It uses the older setup software and I don’t see any place where I can change the number of repeats.

Anyone found a way to make the change with the older software?

If your remote supports changing command repeats, in the app select your remote, go to Devices->Device Settings->Device Command Repeats.

That is where the setting was for my 650 and 700 remotes, not sure if your 880 uses even older software than that or not.

@DaleF have you tried connecting your older remote to the newer software?

@DaleF I found this on a user forum

Try to change the repeats for your cable box .


     - Log into the Harmony software 

     - Click on  Settings

     - Troubleshoot

     - Click on “Cable Box responds to some commands either too many times or only occasionally”

1 Like

I use a Harmony 720 (old remote) and this absolutely solved the problem! I set mine to 1 (I’ve seen other comments saying set it to 2 and that did not work for me)


Thank you everyone for the suggestions. I did get my 880 to work properly by following the directions roraniel gave.

I wasn’t ignoring anyone, just wasn’t getting any e-mails notifying me of the suggestions you left.

thanks again!!

I found another work-around. I had another Harmony remote (650) set up with my Roku 2 DS and discovered that it worked fine with my Roku 3 XDS; no more repeated movements of the cursor with one press. I added the Roku 2 device to my Harmony 700 and deleted the Roku 3 from the activity substituting the Roku 2 instead. It works great now. The “device command repeat” setting is “1” and everything is good again. Just thought I would add this as it might work for others.

I had the same problem for years. Try going to Devices > Your Devices > (choose the device you’re controlling) > Change Device Setting > Device command repeats > Restore defaults. This did it for me. Apparently, you must be sure to have the correct model number in the Device settings when you add the device.