How to perform factory reset

I got my Tablo today and followed the instruction on setting it up. I was able to scan for channels and all and played around with the Android app for a bit. Performance was terrible. My Table is hard wired to my network and I have enterprise class 1Gb switch and access points in my house. All of my other devices performance as expected if not better than most home setups. The Tablo not so much.

My Tablo is running the latest firmware downloaded to day via the Android app. After experience video delays and trying different settings (e.g SD), I decided to disconnect my Android Tablo app and ever since then I have not been able to reconnect, even through Ok now lets try a restart using the little blue button. Ok, nothing seems to happen, no blinky blue LED or any indication that it is restarting. Ok, so maybe that is how it is. I wait for about 10 minutes to make sure that is has finish booting. Nope, same issue. So I unplug the device and wait 60 and then return power. Again, no blinky of the blue LED, waiting 10 minutes before I try to reconnect. Nope same issue. “Connection could not be established”. So, onto ta factory reset. Again, no blinky of the blue LED.

Not a very good first impression Tablo. Please advise.


OK this is ridiculous. Neither my switch nor my AP are reporting the MAC address of my Tablo. I think the latest firmware bricked my not even 24 hour old Tablo. Nice!

I am going to listen to some soft music to relax my thoughts.


Have you tried hard wiring the Tablo to the router? I have my Tablo connected using 5 GHZ WiFi and don’t have problems. My Roku 3 is also connected WiFi 5 GHZ network.

The firmware update that you loaded has been around for awhile. We are still waiting for the new firmware to get released. Did you check power? I know that sounds dumb put no lights, no access, appears to be a brick. Lack of power will give you the same indications. Good luck with it. I was able to get mine up and running in less then a half hour when I got it a couple of weeks ago so I am surprised that you are having so many problems. I am also very happy with the video that is streaming from the Tablo.

Wired or wireless makes no difference. I have a dedicated 100 AMP circuit from the street for my Home Theater. I need it for all the equipment I have in my HT closet. Tablo is on a power conditioner that provides extremely stable 120v AC with less than .0001% THD. So it is super clean power.

Not sure if this means anything but every time I plug power into the Tablo the blue LED lights up instantly and stay lit. It never blinks.


When you press the little blue button for resetting, hold it in for at least 30 seconds. That will start a factory reset.

Ok, so should the blue LED blink or do something to indicate that it is resetting, because I do not think that worked. Both my Android app (after clearing cache and data) and my computer (after clearing browser cache) still list the device as I named it which different from factory.

Please advise,



After resetting the blue light blinks fast, I think after as it acquires an IP address, the blinking slows down and then finally stops, then the Tablo is ready to go.

If yours is not blinking, I would think its time to submit a ticket to support, so they can troubleshoot.


1 Like

Submitted. Not what I was expecting for the weekend. I guess I will have to find something else to do.