Horrible initial experience, but it got better


The initial setup experience needs major work. It fails to complete using many popular browsers. The streaming experience on completing setup is horrible (video stuttering, streaming stops).

The long explanation:

I got a Tablo (2-tuner) for Christmas. I had been looking at the HD Homerun but some family decided I should buy Canadian, so they did for me.

When first trying to set-up the Tablo, the web setup wouldn’t let me proceed. IE 11 had problems, Edge had problems, Firefox had problems. They all stopped stopped or wouldn’t let me get past some point in the setup process. These are not strange web browsers, they are among the more popular browsers out there.

I finally managed to get it completely set-up by using either my iPad (Safari) or my phone (android, Chrome, I think). I forget which. But the point is I went through 4 different browsers before it finally got set-up. Most people I know don’t have more than 2 browsers available to them.

After that, the Tablo said it needed to do a firmware update that would take several minutes. Okay, I expected that and good job keeping it up to date. It took maybe 5 minutes and the system rebooted. Good, not bad.

Upon reconnecting after the reboot, there was absolutely no indication that the Tablo device was doing anything more in terms of updates. No progress indicators, nothing.

Proceed to the next step, scan for available channels. Done (I have 13 of them if you include sub-channels and channels I never watch). Awesome.

Switch to the guide and see what’s available. The interface is a bit slow to respond. Okay, it’s fetching show metadata to display for me. I can accept that.

My next step is to see how well it streams. So, I picked one of the channels it said was coming in strong (CBC) and tell it to stream to my computer. It’s horrible. The video stutters. I switched to the Roku viewer and it’s worse. Every minute or so the Roku starts buffering.

So, I did a quick sanity check, plugged the antenna back into the TV, and checked CBC. It’s coming in clear as ever.

Back to the Tablo, maybe it’s my wifi (could there be something jamming the signal?), so I switch over to Netflix, tell it to stream in full HD (gotta be fair in the test) and everything comes in beautifully without any issues.

I’m still not entirely sure what the Tablo was doing, but it was not handling the first hour (I gave up after that) at all well.

The only reason it didn’t get taken to the store (fortunately there was a gift receipt included) is because I gave it one more shot the next day and everything ran smoothly. I suspect (but have no way to test) that the device was downloading the guide and metadata, which was pushing some internal limits too far.

I forgot to mention that the tablo wouldn’t recognize my mainstream USB2 hard drive (WD something) that first day either. Remarkably, it worked find the 2nd day and is now happily saving video

Point being, if I hadn’t gone back and checked before disconnecting everything, there would be on less Tablo user in the world.

It appears I’m not the only one with this problem. Someone else said something very similar back in October (2016) in the General Discussion forum.

I just got one too, but did not have your unfortunate experience. I set mine up on an iMac without issue. So, not using Windows, I have no way to compare. I did using Chrome.

Glad things improved. To me, I am amazed any of this stuff actually works :wink:

You got lucky in using one of the right browsers. I should have used my iMac to set it up instead of my PC, but the PC was already on.

Me too. I work in the computer industry and I’m constantly amazed at the weird crap people do that works (not saying the Tablo fits that category, I haven’t dug deep enough into it).

I think your theory about it being “bogged down” initially is probably correct. In my case I get about 25 channels and when you consider it’s downloading 2 weeks of guide and program data initially it’s not that surprising. Displaying a message indicating what is going on would probably be helpful. If I recall, TiVo just makes you stay in the setup screen until it has finished downloading and processing everything during initial setup. That might not be a bad user experience improvement to prevent some mostly one-time potential frustration.

I agree. Those particular one-time potential frustrations (anything in the first few days) are what make people return things to the store for a refund. I didn’t but it was very close.

A little tidbit that helped me find out is was my wireless causing a stuttering issue. I went to VUDU on my Roku set up an account then ran the setup in VUDU for streaming quality. That test showed that I did not have a an optimal connection. I then relocated my wireless hardware and tried again. This time I got max quality streaming from the VUDU test. My Tablo stuttering went away. If you have multiple TVs you might want to do this from each set to help you maximise the wireless speed in your house. Airports also help this problem.

1 Like

Off topic, but the thread title made me go immediately here:

"But I got better"


That is how it felt. Horrible experience but it went away.

I know what you mean about difficult setting it up. The 1st one refused to recognize the hard drive. Got a replacement and had hard time getting it to connect. After several different attempts it worked. It was doing great then started having buffing issues when I tried to watch live tv or recordings. I have a Roku 2 XS in the living area where the tablo was set up by WiFi and a Roku stick in the bedroom. It played fine in the bedroom. I tried lowering the record rate to 3, hard wired into the router and still had problems. Noticed a lot of people had this problem with Roku 2. All updates were good. Reconnect it to the main tv and back to wifi and thru my antenna problem still ther of course. Was about ready to return it for a refund when I decided to replace the batteries in the Roku 2 remote and it resolved the problem. No more buffer. There are so many variables to try and sometimes it is so simple as a battery replaced.

Yeah, I traded in my Roku WiFi remote for a standard infrared model.
I found the WiFi remote interfered with my main wireless network.
The WiFi remote is supposed to use an unused channel, but it kept jumping on my main network’s channel.
Google that issue, and you’ll see many complaints, like mine.
Sometimes keeping it simple is smart.

[quote=“Radojevic, post:10, topic:10468”]
I found the WiFi remote interfered with my main wireless network.The WiFi remote is supposed to use an unused channel, but it kept jumping on my main network’s channel.
[/quote]Yep, exact same issue here. It only caused enough interference to be an issue with Tablo on the higher quality settings…

I often wonder when others post about “everything else works but Tablo so its not my network”, if its not the Wifi Remote (or other interference) , but I rarely speak up as often the OP isn’t willing to accept that option.

My fix was to create a dedicated, locked channel 5GHZ connection JUST for the ROKUs…

1 Like