Having problems with the andriod app

Everything else Roku, and ipad work fine. The Tablo is connected via ethernet and all other devices via wifi. The two android devices can not connect to tablo no matter what. There is no VPN on them. Called support they suggested rebooting everything(Tablo, router) which I did. The problem is still the same. The apps worked fine until late friday. I tired uninstalling them and reinstalling them and no go.

Any suggestions as about the only thing I can think of is a factory reset and I do not want to lose my programs.

Did you try clearing the cache data for the Tablo android app? This data may persist after an uninstall/install.

Doesn’t sound like a Tablo factory reset is necessary since other devices are working.

Yeah tried that. That made it at least get to the set up screen. It can find the tablo on the network and when it tries to connect, it can’t load the screen. It is weird. Three Rokus and an Ipad work. Have not tried the iphone but the two android devices don’t work.