Hard drive formatting

my hard drive seemed to format correctly but now when i record i get the gray play button with the line through it. did my hard drive format correctly? or is this some other issue?  

my tablo is connected via ethernet cable as well as my laptop

hard drive: WD My Passport 0740 1007 (1000 GB)

@Ron234 - One of two things could have happened… 

Either your antenna signal isn’t good, or your hard drive has disconnected from the Tablo. 

The My Passport line of hard drives commonly suffer from disconnect issues which is why we don’t recommend them. http://www.tablotv.com/blog/back-away-from-that-flash-drive

If you send a ticket into @TabloSupport they can verify whether this is the case. 

thanks for the info, I went with the Seagate hard drive and it seemed to clear it right up. The Passport periodically disconnects from whatever device it is attached to (didn’t know that at the time). After formatting the Seagate I was having buffering issues from my Ethernet wired tablo 2-tuner to my wireless roku 3. I restarted tablo, router, and roku and this has cleared the buffering issue. Next step will be to purchase a streaming stick for the bedroom (the signal seems to be strong enough to support it). do you recommend this or should I go with another roku 3?

@Ron234 - Glad to hear you’ve got things working :slight_smile:

As for the Roku stick, some users have it and love it, but during our testing we found that the WiFi antenna wasn’t quite strong enough to get a good stream going. 

Perhaps get the stick and try it at home but keep the receipt in case it doesn’t pan out. The Roku 3 seems to be solid in 99% of use cases so that’s our usual recommendation. 

any ideas why the new Criminal Minds didn’t record for me last night? this was my first attempt at recording a show, i had the gray play button with the slash through it.

@Ron234This can be due to a number of things: connectivity issues, inclement weather, or limited disk storage (although since it’s new it shouldn’t be that last one…)

Did you have storm go through last night? We had some wicked weather here at HQ yesterday (sideways hail). 

@TabloTV. I don’t have this issue, but I do have a question about your reply above. Is limited disk space still an issue? I thought Tablo’s newly added feature deleted older recordings to free up space. I’ve been spending my time marking the few recordings that I don’t want Tablo to delete. Should I be deleting old recordings that I don’t want instead? Please clarify.

@jkline - Auto delete is still an optional setting and is not automatically set as enabled. So it could be possible that someone hasn’t enabled it and has run out of disk space. 

Does the number of recordings have an impact on buffering and roku stick performance? I have a number of recordings of Big Bang Theory at this point and notice playback on all of them is horrible. This is less of an issue with live or programs where I have limited recordings. My assumption is that the stick has far less memory for this sort of thing than a roku3. I do seem to get more buffering issues now than when I initially set it up, prior to the firmware upgrade.

Just some observations.  First, Tablo uses ext4, which in general is pretty good at minimizing fragmentation… however, the Tablo uses lots of files… and that’s going to be bad for most general purpose filesystems.

With all that said, does the cost of extreme fragmentation ever become a bigger problem than the speed of USB 2.0 (?).

I think you can certainly get some latency issues that might cause problems.  Not really sure though.

For Tablo, might be better to look at storage as contiguous slots, but not quite sure the best way to implement that.  Btw, this is a typical scenario for all streaming media solutions (well… those that don’t use a general purpose filesystem).

I think it might be interesting for Tablo to look at formatting (long time) with “slots” and using an algorithm to compute the lowest latency.  Of course as SSD becomes larger and cheaper, the need for all of this goes away.

I’ll let the Tablo guys speak as to whether they believe ts to ts or intrafile access latency could possibly ever affect performance.  I mean 9 out 10 times, I’d still expect the culprit to be network, USB to drive or something else.


We really haven’t seen a full hard drive impact playback on the Roku. There could be a few things at play here that may change your experience - though I don’t think the HD being full is one of them. 

Tell me a bit about your setup: are you using the new 720p Roku recording quality? Are you on Ethernet or Wi-fi? What kind of drive are you using? I’m sure we can smooth this out for you - feel free to send me the details on your setup directly.

I swapped the rook stick out with a roku3 and the problem went away. Not sure if the 3 receives a stronger signal or has a larger buffer but in any case - problem solved.

I was recording 1080p and was on wifi

I swapped the rook stick out with a roku3 and the problem went away. Not sure if the 3 receives a stronger signal or has a larger buffer but in any case - problem solved.

Glad to hear your problem is gone @Tony… In our testing we’ve seen that the Roku stick’s WiFi antenna is a bit underpowered. Some people have had success with it but we weren’t able to get it working quite right. That’s why we usually recommend the Roku 3.