Guide Not Updating since Purchase of Monthly Subscription

Hi all,

In mid-November, I bought a 4-tuner Tablo box for my house. After using the box for a few weeks, I decided to take out a monthly subscription to the guide feature. On December 10th, I made the purchase. I just discovered that ever since I did that subscription purchase, my guide has not been updating, and all of my programming information has become outdated. In settings, it says my guide hasn’t been updated in 22 days even though I have manually updated it several times this morning. Is anybody else having this problem?

It seems that the last time I heard about a problem like this, it was because the wrong server ID was entered when the subscription was purchased. The setting menu in the WEB app displays the subscription state.

I think it should say “active subscription” and the “manage” button should be useable.

Hi Zippy,

Everything “appears” to be setup properly with the subscription. When I go to the Settings page, it says I have an active subscription and “Your Tablo has full access to guide data and all features.” I also went into my account at and my Tablo is saying it is properly linked.

I noticed that nothing has recorded since December 24th, which is coincidentally (?) fourteen days after I took out a paid subscription. Even when I go to set a TV show to record, it won’t actually record it. I did a test of an immediate pending live TV show, and nothing happened.

When I go to update the guide, it quickly goes from 0%, 10%, 90% and 100% then keeps saying “updated 22 days ago”. Have tried it on both the web app and both of my iOS devices, and nothing.

I also verified the serial number on the Tablo box with the one listed on my account page, and it matches. :slight_smile:

Time to open a help desk ticket. I’m assuming that the channels you previously saved are actually still tuning/available.

You can always use the WEB app setting page and rescan the channels to see what tablo thinks is currently available. Rescanning doesn’t automatically update the existing channel list. After the scan you can always back out to the previous page without updating.

Manual recording should work until tablo figures it out.

For me this happened a couple of times with the following true:

  1. Recording scheduled for a channel in my channel list.
    Let’s say this channel was 15-1
  2. Rescanned for new channels, and deleted channel 15-1, because its signal was not strong.

My guide data would not completely download anymore, until I deleted all the scheduled recordings for the channels I deleted from my channel list.

Thanks! I have sent in a ticket request already, but with it being a holiday, I won’t hear anything until Monday at the earliest. :frowning: I doubt it is a signal problem since my two TVs are receiving perfect signals and in doing a rescan, it picked up all the usual channels.

I shall wait for a response…

Thanks Radojevic,

Did as you suggested and it didn’t work.


Bummer, it worked for me both times.
Did you try clicking the guide Update Now button after you deleted all scheduled recordings for channels not in your channel list?

Yes, did that. I also tried adding to the guide channels I never had before (in my area we get a few French-language stations). In LiveTV, i don’t have any programming for these stations, something that even non-paid users should be receiving.

One more thing.
Scheduled recordings for shows that are beyond the 14 days that the guide has data for will not show up in apps like the Roku app, except in the Guide section.
However, they should all display using a computer’s web browsers, like Google Chrome, via the web address.
You probably already did that, but just wanna make sure.


Everything is working now!

Found out how to do a factory reset. Did it and started new and the guide updated and is now recording!

Unsure why it didn’t work when I first upgraded to a paid subscription bu it works now, so all is good. Thanks for everybodies’ suggestions.

You shouldn’t have had to do the factory reset. Are you on the latest 2.8 release? Had you contacted the Tablo Support people?

Yes, I put in a ticket but since it is the holidays, I won’t get a response until next week.

Where is the serial number on the account page? I don’t have that on mine.

Is this entered when you purchase the guide?

The serial number is found on the box, not on the website account page.