Got my new Tablo Today

Definitely not the best experience.

The app is terrible especially the iOS app. My goodness its awful, probably because it an HTML app.

Adding channels to my lineup results in a never ending spinner. If I reboot the Tablo I have to reconnect to it via WiFi and do that setup all over again.

Horrible start.

Do you have the new Apple TV? If so an app is in the works instead of having to cast

yes. thats the primary reason I bought it. plex seems to work ok but am looking forward to the native app. No word anywhere on when it will be available though.

Not even beta yet. You can sign up when they ask for it if you want.

Really? Where?

Tablo will make an announcement asking for beta participants when they’re ready for us to be in the program.
Not quite there yet.

1 Like

Sounds like you rebooted prematurely. If you add via WiFi, scan for channels, select your channels, and WAIT (give it 30 minutes to an hour, go eat a meal or something), then once it has downloaded all the information, you should never need to start over from the beginning again. I will agree that the 1st day of Tablo is usually the worst. Trust me, it gets better from here :slightly_smiling:


What ios app? iphone? ipad? I use the iPad app and it works very well, even on my old ipad2.

o the fact that you have to select the channel number in the listing and most of the time tap on it twice is completely counter intuitive. when I first loaded up the app im like “how do I actually WATCH something”

o navigating the guide is crap. you can move the whole guide all around the screen. its just bad coding. again probably because its html.

o pictures, headers, etc at the top get cut off.

o moving from landscape to portrait causes funny bugs with the display.

I guess all their iOS people are working on tvOS. which is fine.

there is a difference between an app that ‘gets the job done’ and a ‘good app’.

Then theres the drive support. Ive thrown 3 at all. None of them work. Formatting gets to about 5% and then just stops.

The skipping and jitters in the picture is horrible. I have a 150mbps internet connection and it says perfect quality on that channel yet it comes through like crap.

Not sure what app you are using, but I didn’t have any trouble figuring it out. I have used IOS, ATV4, Roku, FireTV and an Android Tablet. All work great. Of all that I have tried, the Apple tablet and the FireTV are the easiest and most reliable. The Roku worked, but periodically had issues.

Still I would really like the ATV4 to get the app soon. I have streamed from my tablet to the ATV4 and thought that it was great. A stand alone app should be even better.

My biggest, and almost only remaining, gripe is the audio. Even if I had to buy a new Tablo to get 5.1 audio, I would do it. But the audio issue seems to be way down on the Tablo team’s todo list.


I’m recent to Tablo too. I’m using the iOS app on a 12" iPad Pro (latest iOS version) with none of the issues you are having, FWIW. If it’s on the iOS side, make sure you have everything up to date. Delete the Tablo app. Shut down and restart the iPad. Redownload the app, connect to the Tablo. If you experience the same issues consider a factory reboot of the Tablo (when support tells you).

Have to agree here. I am pretty sure iOS was their first supported platform wasn’t it? And it shows. The Tablo app on my gf’s iphone/ipad is worlds smoother/snappier than on my other devices.

Based on your original post, it sounds like you are using Tablo wirelessly. FWIW, it’s been fairly solid on a lined connection for me… I just recently got mine too, and aside from a small hiccup due to it asking to reboot for a firmware update while I was initially setting it up, it’s been fairly smooth. DVR’d episodes play pretty much instantly for me and channels take about 10-15seconds to start initially and less if I switch to another channel and back. I was wary of the delay based on reviews, but truthfully found that I didn’t really care too much. Admittedly, I’m use to it having had the cord cut for so long and having had to switch apps constantly in the past to watch content I wanted anyway. The lack of any buffering or wait for DVR’d content was a pleasant and welcome surprise. I mostly watch on my roku, but limited viewings on my iphone haven’t been noticeably different. No skips or jitters or buffering issues.

As for hard drive support, Tablo only really recommends two it seems but I had a small 1TB toshiba drive available that luckily worked out.

Best of luck resolving your issues with it.

1 Like

Day #2 is better.

Got a better antenna
Moved to airport extreme (the express wasn’t cutting it especially with everything else in my house).
Got a working hard drive.

Just need ATV app now.
I wish the plex app put the channel number next to the show.
I wish when I clicked on a show in the guide I would get a little menu: play, rec, rec all ( i had to dig for record all ).

Gonna run a test tonight to record 4 at the same time. Cant wait.

Spoke to soon. Now it just non stop freezing and buffering. SIGH

Just terrible:

64 bytes from icmp_seq=62 ttl=64 time=15.9 ms
64 bytes from icmp_seq=63 ttl=64 time=17.1 ms
64 bytes from icmp_seq=64 ttl=64 time=1.89 ms
64 bytes from icmp_seq=65 ttl=64 time=384 ms
64 bytes from icmp_seq=66 ttl=64 time=106 ms
64 bytes from icmp_seq=67 ttl=64 time=490 ms
64 bytes from icmp_seq=68 ttl=64 time=213 ms
64 bytes from icmp_seq=69 ttl=64 time=324 ms
64 bytes from icmp_seq=70 ttl=64 time=775 ms
64 bytes from icmp_seq=71 ttl=64 time=248 ms
64 bytes from icmp_seq=72 ttl=64 time=290 ms
64 bytes from icmp_seq=73 ttl=64 time=307 ms
64 bytes from icmp_seq=74 ttl=64 time=68.8 ms
64 bytes from icmp_seq=75 ttl=64 time=335 ms
64 bytes from icmp_seq=76 ttl=64 time=299 ms
64 bytes from icmp_seq=77 ttl=64 time=123 ms
64 bytes from icmp_seq=78 ttl=64 time=281 ms
64 bytes from icmp_seq=79 ttl=64 time=875 ms
64 bytes from icmp_seq=80 ttl=64 time=95.2 ms
64 bytes from icmp_seq=81 ttl=64 time=27.4 ms
64 bytes from icmp_seq=82 ttl=64 time=788 ms
64 bytes from icmp_seq=83 ttl=64 time=34.4 ms
64 bytes from icmp_seq=84 ttl=64 time=289 ms

86 packets transmitted, 84 received, 2% packet loss, time 85137ms
rtt min/avg/max/mdev = 1.333/83.022/875.343/176.432 ms

Hey tablo, would it kill you to put a REBOOT button in the settings? Is that a super hard programming thing to accomplish?

It’s on the list…


What does all that stuff mean? Doesn’t 2% packet loss mean the messages aren’t getting to the Tablo?

Post your antenna and tvfool report.

The antenna has ZERO to do with the Ping results. Last night it started working ok again after about an hour. I haven’t tested the recorded shows yet.

Skip over this post if you’re already highly experienced with wireless networking, or if you want to be amused by my explanation. :slightly_smiling:

The Tablo has both wireless g (2.4GHz) and n (2.4GHz; 5GHz) capability.

Wireless-g maxes out at 54Mbps, in theory.
Since there’s overhead, and it’s half-duplex, it really maxes out at 24Mbps.

Wireless-n maxes out between 150Mbps - 600Mbps, in theory, depending on network adapter, and router.
Since there’s overhead, and it’s also half-duplex, it really maxes out at a little less than half the theoretical maximums, so around 75Mbps - 300Mbps.

So far we’re good.
Doesn’t seem to matter which wireless technology we use, because any of their thruputs in real life should be more than enough to deal with demands.

Now you throw some real world issues…
Metal objects, like refrigerators
My fat head
Wireless interferance from other devices on same wireless requency: microwave oven; neighbor’s wireless router…

We end up with a lot less thruput, and a lot less stability.

What can we do about it?
Choose the best wireless configuration for your environment.

In my house, my Tablo is hardwired, along with a hardwired Roku 4.
I also use a Roku 2 (2015) via wireless-g.
Why not use wireless-n?
Because the signal travels 70 feet thru 3 interior walls, kitchen equipment, bedroom furniture, and my daughter’s head.
Wireless-n won’t work reliably in my environment.

In my mom’s house, her Tablo, and Roku 3 both use wireless-g.
Again, wireless-g was chosen over wireless-n due to distance, and objects between the devices, and the wireless router.

Both setups work great.