[Edit: Looks Like Tablo is disabling feature functionality to force subscription to guide service]Select to Record from Live TV populates wrong date and no channel or selected show information

[Edit: After pulling up debugger in safari I see that there is an error message that says you need a subscription to initiate recording from channel description. I hope that is just a misunderstood artifact on my part. If Tablo purposely disabled something as simple as initiating recording from channel selected to force users to subscribe to guide, where it worked fine before, I can promise you that is a bad marketing move. Disabling a fundamental feature marketed for this unit AFTER I purchased it and it worked fine would be a terrible way of getting me to recommend this product to others. I feel a strong Medium article coming as I have grown weary of this platform]

After the last upgrade I have noticed the UX for recording has completely changed. Previously I could bring up Live TV select a show from the grid, be presented with record option, and then everything would be pre populated with show name, time, channel, etc. I might adjust the recording duration and hit go.

Now everytime I select a future show from the Live TV grid I am presented with an empty recording option dialog that defaults to multiple recordings. I then have to select the one time tab recording, manually enter a channel (even though I selected the show from the channel grid), manually enter start time because the time seems to default to other times not aligned with the selected show, override the duration that is always at 30min, and the default date is always one day ahead of the current date, I then manually enter the show name. I have also tried initiating this from the record icon in the header feature area about the channel grid but am presented with the same dialog.

FW 2.2.12
HTML Application:
1.1.1 build 716 [201610261413]

@daveobike Hey there! Just FYI, we managed to reproduce this behaviour and we’re working quickly to solve this. Certainly nothing done on purpose! We’re happy to set up you with a trial subscription in the meantime. Just send our team a note.

I can confirm the same behaviour. Same version and build. It is behaving like I have a subscription but won’t record after hitting “Rec” on any screen. If I click an item on the grid, I get a default schedule screen with no pre-populated items.