Dead DVR? No text

I have a quad network DVR. It had been working perfectly until 2 days ago. On the screen, I get the blue on the left and black on the right but no text. I have tried to reboot the power supply and reset button. Any suggestions on how to fix?

Later, I checked TV#2. The DVR/app was working fine. Back to TV#1. I rebooted the TV. No change. I deleted the Tablo app and reinstalled. It is working fine now.

Problem solved.

@modern Have you tried deleting/re-adding the app? It won’t delete your recordings or schedules, just force a fresh load of all of the app data.

I find that it happens too often that the solution to spinning or the message unable to find mytablo upon turning the TV on is to delete and reload the app.

Finding Google Play Store and reloading Tablo app does not make me very happy when I simply want to watch TV! Does the Tablo app get corrupted after a while?

This sounds more like a network-based issue. Setting a DHCP reservation on your router for the Tablo should help.