Constant issue with guide disappearing, channels not populating in guide, etc. How do I get a refund?


So I’m having constant issues with my Tablo Dual whatever. This is my 2nd one (had to return the first that was DOA) and I’ve absolutely had it with these pieces of junk. I live near Boston, have 65+ channels that I get, most with strong signals, and the antenna works fine. I’m on a half gig speed connection. So it’s not that.

My issues are as follows:

  1. The guide constantly goes blank. Not all the time, just 80% of the time. Once it goes blank though it never comes back. If I re-enter my zip code and repopulate the channel list a few shows here and there will fill in on the guide. If I actually click on the channel it loads fine and I can watch it, but I can’t use the guide to see what’s on. I also can’t schedule recordings.

  2. My recordings constantly go blank; they come back sometimes when the guide comes back. I’m constantly trying to figure out if I missed episodes of shows, or what’s going on.

  3. The app itself freezes up for a minute or two at a time. It’s not downloading anything, because when it unfreezes the useless blank guide is still there.

  4. It misses recording things 75% of the time, probably because the guide on this piece of garbage is blank.

This is on a Firestick 4K. I paid for a subscription to the guide, but I want my money back. This thing has been a pain and I’ve spent 5+ hours having to troubleshoot it at this point. I can’t believe a product that’s this awful was actually rolled out to the public.

Maybe you are super unlucky getting two bad units. Maybe your unique location is problematic. Maybe xyz… You seem to have made up your mind that this product will not work for you but that is not the experience for many (most?) of us. Many of us are very satisfied with the product and the company behind it, Good luck with another solution that might work better for you.

Have you opened a ticket with @TabloSupport? They can access diagnostics that we can’t that may give some insight on the source of the problems you are encountering.

Having said that, the great part is there are several other options out there you can try if Tablo isn’t meeting your needs.

Do you have a different hard drive and cable to use as a test. It seems like the current drive may be “napping” while on the job. (Just be sure that it is a drive you can erase all the data on, as Tablo uses a linux-based format, and will require re-formatting.

Another “Have you tried…”
Have you connected to your Tablo via a web browser ( or thru another device (Tablet, Smart device)?
Maybe the problem is with the Tablo app on your Firestick.

I use Roku and throughout the years, I’ve seen the Roku/Tablo app do some things that were not related to the Tablo unit (missing thumbnails, occasional crashes, poor video quality, buffering).
I have also found that wi-fi connections have more issues than direct connections via ethernet.

Using my PC has always been the method I’ve used for determining whether my problem is the Tablo unit or a connected device.

Good luck. I hope you get your issues with your Tablo worked out.

– Happy owner of a 4-Tuner Tablo for 5+ years

I am a happy owner of the Tablo using Firesticks for 7 years now. I found this same issue over time and found that the Firestick 4k is so much faster and alleviated the problem.

I run a channel scan every week or two. Ran one today; added a couple of new channels and saved the new channel lineup. I then went to the live screen to see the new channels, but the guide was blank. Also, no recording was taking place. I rebooted my Tablo, but no change. Did another channel scan; still no change. I noticed along the way that a guide update was trying to run but would not complete. After another reboot and trying a few other options, I went back to the channel scan and removed the new channels; updated the channel list again; ran a guide update. This time, the guide update completed all programming info appeared in the live display. I don’t know if adding a channel caused the problem and then removing it solved the problem, or if there was something else going on with the Tablo network, but it works now.

By the way, I have a 4-year old Tablo 4-channel running V2.2.32, a WD Elements 1TB hdd, and a Roku Streaming Stick. So far, this setup has been very reliable, so I’m hoping this was just a minor glitch.

The Live TV guide screen was blank for all channels, or just the couple you added?

The guide was blank for all channels including the ones I added. I was able to select channels and open programs. After repeating this a few times, one or two channels appeared in the guide. It was only after deleting the new channels from the channel scan that the guide fully refreshed and was viewable.

If you re-add the new channels to your lineup now, do you see the same problem?