Commercial Skip gone already

I thought commercial skip was going to be active till Feb 6? I log in today and now my commercial skip is gone. Yesterday on Facebook they had no need to hurry to sign up for as the subscription starts right away. Did they change their mind on this like they have on other things, I am really wondering if they got a new CEO or something. Worried only about the money and not about keeping long term customers happy.

I am also running into this problem. My bet would be it is just a coding issue with applying the free premium to everyone until February 6th. I would assume they can resolve this.

I was going to go to premium anyway so I just went ahead and bought it early which did bring back commercial skip. At under $2/month not getting the 3 weeks free is not that horrible but still would have been nice if this bug didn’t happen.

I just paid the $20 and now all my check marks are back and commercial skip
Is now back functional…all my last night and previous recordings are all
back to normal …phew…so go to your subscription page …
and add premium service :sunglasses:

Edit…go to Tablo settings page and hit refresh under subscription

“This feature brought to you by… skip…”

All I had to do was hit the refresh button by the subscription and it added another button “Options” and then commercial skip started working again. I didn’t have to subscribe to the premium service, at least not yet and probably won’t when the time comes.

Yes, correct for anyone else than runs into this issue…just hit refresh…we were going to buy it anyway :sunglasses:

I had to update my credit card. I added the $20 per year subscription and it had an invoice sitting there unpaid with a note that said to update my credit card. Which I then did. Now wondering how long before it’ll retry to process the payment :smiley:

I so should have found that announcement first. Good to know they already resolved it by just refreshing.

I have refreshed mine but the commercial skip option is still missing

Try hitting REFRESH on your TV GUIDE DATA subscription in settings one more time.

Then can you check the lines in the player on completed recordings… are they yellow or grey? If they’re grey you may have accidentally turned the feature off in the player.

  • On Roku - Press down on the D-pad for Options
  • On Amazon Fire TV/Android TV - Press down on the D-pad for Settings
  • On Apple TV - Swipe down on the touchpad for Settings

I was able to get this to work but lost a day CS. Are you going to let it go to the 7th or even better through the weekend? I am trying to get everything off that I have recorded that has CS. Plus I am recording new shows.