Can't watch recordings

So I got an email saying my payment was unsuccessful from tablo. I figured out that my card was trying to be charged for the monthly guide fee I assume. Well a few days later the guide is gone from roku but recordings are still there. I tried to play them but tablo app crashes back to main roku screen. Do I need the guide enabled to watch recordings!?

No this issue is with the new Roku firmware update.

Delete the Tablo channel from the Roku, power cycle the Roku and then add the Tablo channel from the Channel Store (it is now an official Roku channel).

I tried your steps and the problem still persists. As soon as I click the “episodes” button is when it crashes. Like its failing to load then.

There’s a known bug where the Tablo channel on the Roku just does not find a Tablo or it crashes upon opening due to the new 6.1 firmware on the Roku. Can you navigate to the recordings at least?

More relevant questions:

  1. Which Roku? Please provide model number as there are multiple Roku 1s.
  2. What firmware is on the Roku?
  3. Which version of the Tablo channel is on the Roku? In the main screen of the Tablo channel hit the * button.

@tmann05 This appears to be a bug with the Tablo Roku channel. We’ve identified this and have pushed a fix to Roku - we’re just waiting for it to be published.

Tablo I just found it odd that it happened as soon as my TV guide subscription expired. It’s a roku 2 xs