Can't sign up for paid service


#1

My new unit is working well with the free trail service but is not allowing me to sign up for the paid version.

Any things to try?

Thx


#2

What portion are you stuck at?

Perhaps you didn’t choose the correct type of Tablo from the selection screen? If you picked the type of Tablo you don’t have, it may reject the serial number:

https://www.tablotv.com/blog/tablo-guide-data-subscription-store-walkthrough/

If you keep running into issues, don’t hesitate to touch base with our support team:

www.tablotv.com/ask-tablo


#3

I could not sign in. The system did not recognize either my user name or password (no way to tell which, or both)

Tried the Forgot Password link which said it would send me temp login info
Tried that 2 or 3 times (checked junk a spam filters too) but nothing ever came

I had previously given the unit serial number and user name and password.
Seems the system could not find that info, so I re-registered (same name/email and password) and can now get it.

Please get back to me that everything is configured correctly and working as expected.

Thx!


#4

Not that it’s a huge deal but you might want to remove that picture and PM it directly to @TabloTV or @TabloSupport so that your MAC address isn’t out on a public forum.


#5

Good idea. Will try to remove the photo


#6

You should be able to see your subscription status in the settings screen of your Tablo app. If it shows ‘Active’ you’re good to go!


#7

I took a few days for the system to sort out I had a paid account
but it finally did. Thx