Can't Play Recordings with Remote Access- Fire TV Stick

When out of town with Fire TV Stick remote access, Live TV works perfectly and I can delete recordings, but when I try to play a recording nothing will play. I can see the recording, but when I start playback the play bar time shows 0:00 and does not advance. I have the Tablo 4 tuner network version which works flawlessly at home. I paired the Fire TV Stick at my home location before traveling and remote access has worked well in the past. The internet connection there at the remote location is very good and Netflix plays without a hitch. I can play recordings on my iPhone, so I am assuming this is a Fire TV stick issue. Any thoughts?

I have a Tivo Stream 4k which does something similar. It uses Android TV, like your Fire TV. I can play recordings with remote connect if it is set to Full Quality, but it has lots of buffering because of internet speed. If I lower the quality I get a “failed to load video” error.

I understand that anything other than full quality requires a tuner to transcode the video, but this is a Tablo Quad and I know a tuner is available. I’ve tried this many different times and always get the error.

I can play live TV at any quality, and delete recordings, similar to your experience.