Can't get ports open for Tablo Connect

Hi, Tablo is working great so far!  Former user and I am loving Tablo!  I can’t get the 3 ports open for Tablo Connect to work.  I am using a Netgear DGN1000 router/ADSL modem.  I’ve tried a TON of ways to open the ports and can’t get it to work.  Since my router has an address of 192.168.x.x does that mean that it’s a private address and it can’t broadcast to internet?  I’m not sure what the deal is, I’ve tried so many ways to open the 3 ports that need to be open and I can’t get it.  Any suggestions from anyone?  Thanks in advance for any help!

Assing your Tablo a static IP and then in the web GUI for the router port forward the ports you see on the Tablo connect page to your now static IP address assigned to Tablo.

Ok, so how to I assign my Tablo a static IP.  I tried making an IP reservation in the router setup so that the Tablo had the same IP address all the time.  Then I routed the three ports Tablo was requesting to that “reserved” IP address.  Still did not work.  I also tried forwarding those three ports to my computer’s IP address and then went to a website to check if the ports were open and they still were not.  I figured if I could get the ports to be open when sent to my PC, I could change the forward address to the reserved address for the Tablo and that would work, but I couldn’t get that far.  Any other ideas?  By the way, my router uses NAT, does that change things?  Thanks!

I tried creating a service for ports 21130-21132 and made an inbound rule in the firewall rules.  I have a static IP address reserved for the tablo.  Tablo connect still says I need 3 more ports.  Attached is an image of the log screen of my router.  You can see that the “Tablo” rule I created shows up as a match in the log.  Still no go, though.  

screenshot of log

Thats not quite right… try this:

Thanks for the response.  My router configuration screen does not look like that, so I have a couple questions.  For the WAN address, you have 31887, 31880, and 31883.  Where did those come from?  Are those the ports that your Tablo is requesting?  It looks like you are routing a stream from port 31887 to port 8887 (and so on), is that correct?  I have not found a screen in my router configuration that allows me to forward from one port to another.  I can enter a port and then send it to a LAN address, not another port.  I have a Netgear DGN1000.  Let me know if I am understanding your screenshot incorrectly, but I think I see what you’re doing and I’m not sure how to do that on my router, if it’s even possible.  

@RPingrey Stick with the ports the Tablo is giving you - these may vary depending your local setup. I found this port forwarding guide for your router:

Let me know if this helps!

Thank you for the response.  I actually already followed the steps listed from the link you just posted.  Go to the link you posted and check out the screenshot just under “Inbound Services” a way down the page.  You’ll notice there is a “Send to LAN server” box where I presume you enter in the address of the Tablo (is that correct?).  However, there is no place to enter a port number to send to.  If I understand correctly, I need to forward data from, say, port 21132 to another port, say port 80.  I know how to create a service for port 21132, but I do not know how to forward it directly to port 80.  There is no place in the configuration for that.  Just a place to send to a LAN server, not another port.  Any other suggestions from anyone? Thanks for trying to help, this has been driving me crazy!

Yeah sorry - I didn’t specify… those are the ports that Tablo gave me… I am running aPFSense router on an atom board.

But i was just posting that pick to show that you have to go from External ports (shown above in my pic) to the internal ports for the tablo… thats all

sorry for confusion.

@Rpingrey, based on the documentation of your router, it looks like your router just doesn’t support port forwarding to specific inbound ports.  What I assume it does is forward the traffic from the port defined in the rule to all the ports on your internal system.

So first I would try setting up 3 individual custom services, one for each external port (5 digit port number).  Then create three individual rules, pointing them all to the Tablo’s ip address (which needs to be static).

If that doesn’t work, then you will need a newer router to use Tablo Connect (look for ones with UPNP, universal plug-n-play, so that you don’t even have to create rules yourself).  

Thanks snowcat, I appreciate your help.  I tried exactly what you stated (3 services for the external ports, then 3 rules pointing to the Tablo), except that I’m not 100% sure I made a static ip address for the Tablo - but I think I did.  In the router configuration I created a “reservation” for the Tablo so that it kept the same IP address.  I tried rebooting the router a couple times and the Tablo’s address stayed the same, so I think that worked.  Also, I do have a UPnP router - that’s the confusing part!  I even checked in the router configuration that UPnP was turned on and it is.  I actually tried turning it off one time to see if that would make those rules I defined work.  No luck with that so the UPnP is turned back on.  Any idea why UPnP isn’t taking care of this itself?

I saw that in the router documentation as well.  I think the problem is that since it can’t define specific inbound ports, the Tablo can’t take advantage of the UPnP feature.

I have successfully set up port forwarding on a UVerse NVG589 (required manual port forwarding) and a Netgear Nighthawk (UPnP).   For my Nighthawk, the Tablo set everything up (though until I finally set up a static address for my Tablo, there were multiple entries for each internal port).

Ok, thanks for you help.  I guess I’ll look into a new router and hope that the UPnP on that router actually does the job.  If anyone else has any suggestions, please let me know.  Thanks!